Revit Multiple Type Name Set

Hi, community, i’m again here trying to set multiple Type Names in Revit and facing same issue.


I can see that there are examples where people rename types, but in my case every time i try to rename types in my projects i face same error (as you can see on screenshots)
I would like to understand what cause that issue and how to avoid it. In my workflow I use Excel file to find existing in project types and rename them according to excel. I Have a lot of types in projects by the way so i need to change them.
Thank you! :slightly_smiling_face:

Can’t see your full definition but one reason might be you are inputting an element instance instead of Element Type?

1 Like

Mykyta,

If Mucahitbgoker suggestion doesn’t fix it can you provide the two errors in the Red Balloon? Thanks

1 Like

@mucahitbgoker , @Japhy :pray:Thank you for your suggestions and sorry for the late response, here is the War in my country right now (Ukraine) :pensive:, so wasn’t able to reply for some time.
FYI: the issue was solved after restarting revit. I have no idea what could cause that, i will get back to that next time i face it again.

2 Likes

No prob @m.onopko , stay safe🙏

1 Like

And so what city are you in now?

Hi @Mikey a lot of people had to leave their houses, so do I. Temporarly moved to the west of Ukraine to keep working and pushing the economy. We will have a lot of cities to repair and to rebuild. So for the moment we can just help each other with everything we can do and to support each other.

3 Likes

Glad to see you still have internet connectivity