Revit and Rhino Coordination

unhandled

#1

I’m trying to coordinate a rhino with a Revit model. I am trying to import a Revit model into rhino, so I can adjust the Rhino model to fit. Although, when I import/ insert the Revit model into the rhino model, I am getting incorrect geometry importing.
Does anyone know what is causing this issue or how to fix it? Thanks


(Margaret Becker) #2

Can you post an example (maybe a part of your model) Revit file, so we can see the problem directly?


#3

What file type are you using to export out of Revit. 3D dwg?


#4

I have tried to use Autocad 2004, 2007 and 2010 and I had the same problem with all of them.


#5

Do you have autocad or way to look the dwg file, to check and see what that looks like. That would tell whether or not it was a Revit export problem or Rhino dwg import problem. I you don’t, if you post the file I can look for you.


#6

The problem does not appear in when I open the file in Autocad. The problem only happens when i am inserting or importing a larger file. Does Rhino have a maximum number of polys that it can upload?


#7

I can’t answer that but may someone else can. Although I have never had a problem bringing in large dwg files into Rhino from Revit.

If you isolate just that geometry into a dwg file does cause come in correctly? I am guessing not as it looks like it has something to do with the surfaces not getting trimmed correctly Rhino.


#8

Sorry for bringing up an old topic, but I have the same problem (Rhino 5 SR5), viz attached screenshots.

DWG: Test_Chair.dwg (124.1 KB)

After some experimenting, it looks like it’s partially a Rhino AND Revit problem; I tried to open the DWG in Inventor and it didn’t like it as well. Still, most application I tried imported it fine.


#9

This isn’t a poly problem. It seems to be a NURBS trimming problem. I wonder if it has to do with tolerances? Is the tolerance in the Rhino file the same as the Revit file? For some reason the curved surfaces aren’t being trimmed by adjacent surfaces.


#10

If you “open” dwg’s in Rhino instead of “importing” or “inserting” you shouldn’t have anymore problems.


#11

Not necessarily, this file was a dwg, opened directly in Rhino… some surfaces are being un-trimmed - and sometimes they end up with a massive radius so, when first opened, the model is a spec and all you see is this massive circle on screen. Confusing until you realise what’s happening.


(Pascal Golay) #12

This file looks wrong either way as far as I can see- there is something goofy going on with the corner of the back - @DaSteenMachine, is there meant to be a detail of any kind there at all?

-Pascal


#13

Sorry to bring this up again. But I’ve been encountering the exact same issue. Opening rather than importing/inserting seems to help greatly, but there is still some odd geometry that is being created. Has anyone found any kind of real solution to this issue or identified what is causing it?


#14

Hi all, I just ran across the same issue. The problem occurs in 64bit, but it imports perfectly to 32bit. You can copy and paste it from your 32bit rhino into your 64 bit rhino, and that should be that! Hope this helps - thanks for the open dialogue!


(Pascal Golay) #15

Hi Erin - are you using Import or Open when it does not work?

-Pascal


#16

import


(Pascal Golay) #17

Hi Erin - on Import, the current file settings are used - that is Absolute tolerance - and my guess is these are looser in the current file than when Open is used. Try setting DocumentProperties > Units > Absloute tolerance to say .001 and then Import - is that any better?

-Pascal


#18

YES! that fixed it! Thanks Pascal!


#20

I’ve been getting similar errors with missed trims on NURBS objects exported as ACIS solids from Revit. AutoCAD seems to be able to read them in correctly, but Rhino creates circles, cylinders, and tori. Using Revit 2017 and Rhino 5 on a 64 bit machine, I’ve tried:

  • Exporting from Revit using different units (exporting as mm usually produces best results)
  • Raising/Lowering each property in DocumentProperties>Units (Raising increases number of errors, lowering helps, but does not stop errors.
  • Using the 32 bit version of Rhino (no change)
  • Using open instead of import (no change)
  • Using different file templates as a starting point (mm small objects works best)

Attached is an example chair that imports with varying degrees of errors, and an image of my best attempt at a clean import.

Is there any good documentation out there that will shed some light on how/why these errors occur? Not sure if I should keep poking around Rhino settings, check Revit, or if it’s some combination of the two.

image
ChairTest2.dwg (3.6 MB)