Reset box edit

Hi All,

Strange thing, which now that I read some other posts, seems more common sadly. I have used Box Edit alot, but just now not only did Box Edit not display the correct dimensions its also froze so everything was the same dimension and also when I tried to input an addition to the Z axis size to an object, lets say 10" to 13" its randomized the modification to 14.063254 blah blah blah. Whats happening?
I restarted Rhino, and without selecting anything, the original values where still in Box Edit from before, no 0’s like it should have. Is there a fix or a reset command?


1 Like

Hello- I believe this is the same as

It looks like it was fixed then re-opened.

Pascal, I dont see the solution, or is there not one?

Hello - it looks to me like the item is still open for Mac (above) but not Windows Rhino - it should be fixed on Windows ( for, it looks like, the SR 12 release.


Is this an update to rhino? When I run the Update check on Rhino it says I’m up to date. How do I force an update?

pascal, my rhino version is showing 6.10 but the fix you reference is for 6.12. How do I find the update to 6.12?

So, an update came about and updated to 6.11. Still no dice, box edit failed about 3 hrs in. What is going on?

Hello - sorry - here’s an SR 12 build - give that a try: