Problems with box edit and make 2d rhino 6


Recently started using Rhino 6, and sad to say it is causing a lot of problems for our workflow.

We use box edit extensively which was a very solid function in Rhino 5. it is now completely unreliable.

I’m also finding make 2d quite often simply doesn’t work, no crash, no error message, just nothing.

Some other small issues:

  • objects on hidden layers that are grouped with un-hidden object are selected when selecting the visible geometry (hope this makes sense) and appear in files exported to excel. Can this behaviour be changed in a setting somewhere?

  • the ‘broken history’ pop-up window causes us to hit return about an extra 1000 times per day as it pops up every time we move a dim line.

the list goes on.

sorry for the rant. At the moment, we’re considering going back to R5 until R6 is a bit more stable.

any help would be greatly appreciated.


Hi John - can you post or send us (, to my (Pascal) attention) an example of BoxEdit and Make2D not being reliable? and can you also tell me what version (Service release) of V6 you are using (The SystemInfo command is best, just paste the results here.


Thanks Pascal, I’ll do that.

details below:

Rhino 6 SR10 2018-11-4 (Rhino 6, 6.10.18308.14011, Git hash:master @ fe550872b75586dc406c587a5ca01f205673c8f1)
Licence type: Commercial, build 2018-11-04
License details: Cloud Zoo. In use by: john ()

Hi John - I got your file, thanks, I’m taking a look.



This is my first ever post, so not sure whether I go right about it.I am on Rhino vs 6, latest update.

For the past few days my box edit, Z-values only, do not correspond with actual object size. Scaling is completely out of kilter. I tried to fix problem by re-scaling but nothing worked. Un-installed Rhino Vs 6 3 times now.

Like so many others with seemingly similar problems I use this feature all the time and it must get fixed urgently.

Can you give me some input here?

Kind Regards

Martin Janutsch[date=2018-11-15 time=00:00:00 timezone=“Africa/Johannesburg” format=“LL” timezones=“Europe/Paris|America/Los_Angeles”]

I’m unable to reproduce that here from the information in this post.

In your picture, scale is set to 1,1,1. Is that wrong?
Please try to provide detailed steps to reproduce this issue.

Yes, the Z-scale of 1 setting is most certainly not a true reflection of what the box editor actual does. By the way, it only effects the text. The object itself scales correctly but the text in the size editor is incorrect

Hi Wim

I am hoping the 3 uploaded pics document my problem:

When I draw a cube of 500x500x500 and open box editor the size text reflect the true value.

Picture 2 shows a change in height to 600mm, The Z-scale number changes to 1.2. The cube adjusts correctly when I enter “Apply”, but the Size text changes to 720 and the scale returns to the value of 1.

Kind Regards


I can duplicate what you are seeing. When you enter apply the cube scales properly and has a height of 600. However the display panel for BoxEdit updates to show what would happen if you scaled again by a factor of 1.2, implying that the object has a dimension of 720, not 600.

@pascal @wim This is either a bug with the display panel updating improperly, or a “feature” based on an assumptions the user would want to scale by the same factor twice. My guess is it is a bug. I wonder if this is the source of several complaints about BoxEdit not working properly in V6.

Hi David - thanks, yeah, it is a bug and has been fixed.


Thanks for the head-up. I was about to down-grade to 6.10 because I wasn’t able to reproduce this here on 6.12.

I’m currently using Version 6 SR11 (6.11.18310.7201, 11/6/2018) and it isn’t fixed in it.

I’ll see if I can find the YT item - I could not reproduce here either, btw, but Mary could.


1 Like

This problem is a bit different than what is described in that YT item. Could be the same root cause though.

@Pascal I experimented some and the problem appears to be with the “z” dimension. I’m using BoxEdit with the keyboard and mouse.
Create an object.
BoxEdit and change the size of the object in three dimensions.
Close BoxEdit
Scale the object using Scale
Open BoxEdit and select the object - the z dimensions shown is carried over from the previous use of BoxEdit.
Close BoxEdit
Create another object of a different size.
Open BoxEdit and select the new object - the x and y dimensions are correct, but the z dimension is the old dimension.
Moving objects doesn’t do anything.

Hi David - thanks, I’ll poke at it some more and make sure that YT item is in fact working now as well.


Hi Pascal

What is the usual turn-around time for fixing this type of bug?

We don’t operate with usual turn-around times.
If this specific issue is, in fact, the same as the one in RH-49211, then it is already fixed in SR12. If it is a different issue, then it doesn’t look like we are able to reproduce this…

You could install the version that I’m currently running to check if the issue is fixed.

noticed this last week too, make a simple object, open box edit, adjust one of the dimensions in the size, x,y,z, screenshot attached, see z size, I typed in 1050 and for some reason it displays 882. The object is correctly sized at 1050 though.

I’m confused now - did you check this with the 6.12 version that I linked to?