Renders are partly covered with coloured background for unknown reason

Hi all, I have a small issue with my renders…

The problem is quite simple. When I render, I somehow always get a coloured background on the render and I have absolutely no clue why.

I initially thought it was a background/wallpaper so disabled the wallpaper on the rendered view but no luck. Do you have any idea of what this is caused by? Is it possible it’s something to do with where the CPlane is located, or my multiple Clipping Planes, or lights?

A small hint is that when I render a section view of my model, the coloured background only appears at the bottom of the screen while when I render a floor plan view of my model, the coloured background is on the whole render, as pictured below.

Sorry my Rhino file is very heavy so will attach through a Google Drive link: 20230118 v2 (PLANS) v2 (Duplicate) copy.3dm - Google Drive

Your help would be greatly appreciated!

There were no textures saved into your file, so I can’t see the same as you do.

I’m assuming you rendered with Rhino Render from Rhino 7.

With no textures in I see:

No groundplane and background settings for rendering are

I don’t see where you should get the brown color from…

Thanks so much Nathan for testing it out!

I actually rendered it with V-Ray and not with Rhino Render.
Does it mean it has to do with something / some material from V-Ray?
It’s very strange though as I don’t have any object that is that high up…

I’ve rendered from an angle, and it’s all coloured in that case…

Ah, I missed that this was in the V-Ray subforum, sorry! Unfortunately I can’t help with V-Ray, but probably @Micha or others can.

It is the V-Ray Sky Procedural Map. If you rotate your view you will see it:

Another thing is to disable the volumetric environment. for your plans and sections.

I like your design, very intriguing idea.

For me it looks like a sky is in the background and a half dome light covers the upper half of the environment. Is it so?

I can confirm that the sky covers the top hemisphere and a dark brown volumetric effect covers the bottom. removing the volumetric effect solved the problem on my side.

@tay.othman @Micha

Thank you so so much for investigating the issue and providing a solution. I really appreciate it.

While I understand that ‘Volumetric Effect’ solve the issues, I would like to understand the issue a bit better if you don’t mind.

As you two kindly advised “a sky is in the background and a half dome light covers the upper half of the environment” and “a dark brown volumetric effect covers the bottom”, does it mean that the coloured background was caused by the volumetric effect?

I’ve previously rendered the below image, how come the volumetric effect didn’t affect this render but affected the plans?

Thanks a lot!
(Tay: thanks for complimenting the design! It’s my end of the year architectural project haha)

Some thoughts:

  • the sky is from the Rhino document sun, which can be found at the Asset Editor → Lights

  • the dark area is caused by the strong dark volumetric environment with the little height of 5000mm (5m). Set a realistic height (for example 50m) and adjust the parameter like wanted. Or disable the fog. Also you can disable the fog for the background only. This looks also better.

1 Like

Thank you so much for carefully clarifying both factors! It all makes sense :relaxed: