Rendered viewport mode blown out?

How come materials and textures in the Rendered viewport mode look all blown out? I also see it when I run EMap command. It’s as if there is too much light in the Rendered mode, making everything look way brighter than it should be. Anyone else have this problem?

thanks,
d

2 Likes

It’s a known issue. Go into the Rendering settings and turn off “Skylight” and it should appear more normal.

Yea I’ve had this same problem, its somewhat recent because i didn’t notice it before this semester in school. Thanks, turning off Skylight helped a lot, i hope they fix it soon :slight_smile:

Thanks for mentioning this. I didn’t find an existing bug report so I filed a new one http://mcneel.myjetbrains.com/youtrack/issue/MR-1827

@dwalden, @decibelguitars - did you turn on the “Skylight” manually?

If so, this is a known problem that we won’t be able to fix with Rhino 5 - it has to do with having both a white environment and skylight on.

However, if skylight is turning on without your help, then there’s a bug somewhere we need to fix.

@andy - did I describe this properly?

I’m not dwalden, not decibelguitars, but I can confirm that in my Rhino the Skylight wasn’t on by itself.

I have an idea for a new kind of bugreport, to improve the system. Anyone interested to hear about it?

Sure. But can you also tell us what’s wrong with the current system? --Mitch

FYI, i just opened a file i hadn’t opened in a couple of months, (prior to the introduction of the new rendering engine) and it opened up with Skylight on by default.

Can you go back in Versions and get the file that you opened 3 days ago? If so, please send it to me using this link: http://www.rhino3d.com/upload/?to=brian@mcneel.com This will help us diagnose what setting is causing this problem.

File sent!

In my case, the problem is directly connected with the sliders in Rhino Options/View/Display Modes/Rendered/Shadows.

with “Use advanced GPU Lighting” set to OFF:

Shadows must be set to “On” otherwise i have maximum blow out.

If i play around with the sliders, i get exposure compensation that comes from shadow manipulation.
In particular these sliders work as exposure sliders, believe it or not.

The top slider Shadow size in general makes image darker when maxed out.
Soft edge makes it brighter when maxed out.
Edge blurring just makes shadows softer no exposure change.
Self Shadowing has a drastic overbright effect even when one click to the right.

If you make the correct balance the exposure is quite accurate, yet is is annoying that when you alter viewport it jumps temporarily to the overexposed, till viewport is left still, due to low framerate. i haven’t got passed this n matter nvidia or rhino settings (660 GTX 2GB)

Thought that changing Shadow color would have a subtle effect kind of Ambient Light control. But is brute and psychedeli, ha.

with “Use Advanced GPU Lighting” set to ON:

See sliders above, with the difference that All sliders work more smoothly (changes are mellower) and “Soft Edge Quality” must be at least one click to the right, otherwise you get black shadows.

At least in both cases when you drag objects (ie. to change size or mapping) exposure stays the same but frame rate is very low.

All the above for a specific scene i have, interior, lots of area lights, v-ray materials. I guess with each scen you may have to fiddle with the sliders.

A way to avoid over exposure could be to keep light multipliers down and use exposure control in final render only, but it doesn’t work.

You can setup a Custom Lighting Scheme in Rhino Options/View/Display Modes/Rendered, but get lights from scene button doesn’t work, even if you create dedicated light for that.
Manual works but it is a pain.

Best thing for me (for texture mapping etc) is to Use Default Lighting Schem with a R50G50B50 Gray for ambient light, Advanced Lihting (reflections) ON, and Shadows turned off.

old conversation but maybe someone like me will and up here, cheers :slight_smile:

Also a high “PerspectiveAngle” will show your model more blown out / bright