Render settings with tubular skylight

I have created tubular skylights with glass dome and no dome, as can be seen in the first image.
Tubular skylights-3

I used a tube, sweep1 and I created holes in the ceiling, the diameter of which is 14".

Silver material is used for the tube and glass for the one (1) dome.

When I render or use Raytraced with the tubes in place, no sunlight can be seen inside the structure. When I render without the tubes, light enters the structure.

I have included my render settings.

I am doing a study on how effective different forms of tubular skylights and diffusers can be in a 1-2 story structure.

What am I doing wrong?


you should include an example 3dm, there are too many variables here to say much otherwise

@jdhill Thank you for the suggestion. I have attached a copy of my file.
TubularSkylight.3dm (1.1 MB)

Raytraced and Rhino Render don’t have caustics that support this use case, unfortunately.

I’d be interested to know if @jdhill 's Bella engine does.

ah, I thought I had read something about cycles adding caustics (and yes bella will do this)

@Edward_Sager as Nathan says, it appears this cannot currently be done in Rhino’s Raytraced, because the light is bouncing off specular (smooth, reflective) surfaces (and in one case, also refracted through a glass lens) before arriving at the interior surfaces where you wish to see it – aside from that your model looks fine (the main uncertainty, and why I wanted to see a model, was about things like modeling glass with proper thickness, and such)

Can we see a render? :slight_smile:

sure thing (I changed the model a bit, closing the open end of the room)


Cycles in current Blender is able to do something like this, but not the aged version Rhino 7 is built on.

1 Like

nice :slight_smile:

I was trying to see where I could get with putting a bit of roughness (this is 20%) in the tube’s materials

then I thought to try in rhino 8, but for some reason there, it seems the walls of the room are invisible to the sun, so it’s just all bright inside (this version is his model, unchanged)

not sure what might be causing that, but also I’m not on the most current rhino 8, will switch after a few more days

More likely you need to toggle away from Raytraced and back again. Sometimes lights get confused.

Below latest Rhino WIP, just fresh from the press

sweet :+1:

Wow. Beautiful. Speechless.

@nathanletwory I wondered if Blender might be able to do this. My problem with this is that I have never been quite good enough to import models into Blender without a lot of cleaning to do.

I might just be a messy modeler.

Latest Blender has caustics yes, I don’t know how good they are though as I haven’t played with them. The test I posted was a quick setup in Blender 3.6 alpha, but you need to enable caustics for all objects for it to do anything.

You could try the import_3dm add-on. I haven’t checked if it still works with Blender 3.5 and 3.6 actually, but for simple geometry you have in this setup it shouldn’t be too hard.

That said, I’d first make some simple tests in Blender directly before worrying about data transfer. I am not sure if Cycles will give you the quality you probably want. Bella here looks much more convincing.

@nathanletwory Thank you for the suggestions.

I am trying out Bella and would love to install the Import 3DM in Blender, but it will not install on Blender 3.4.1.