Render not outputting alpha channel with log tone mapping

Having an issue with saving renders out from WIP on macOS.

MacBook Pro 16" with AMD 5500m
Big Sur
Version 7 BETA (7.0.20309.06004, 2020-11-04)

When performing a render, I have transparent background selected and then saving out files with the box checked for transparent background for formats that support it, I just get a black background (not transparent).

When selecting the different channels in the render dialogue, the alpha channel is completely black. The depth channel seems to be capturing the background correctly, ie it is black and the rest of the model is grey.

After much digging, it turns out that if ‘logarithmic tone mapping’ is turned on, it kills the alpha channel.

Any other setting seem to work fine. But I need Tone mapping and I need the alpha channel. For the meantime, I’ll export a separate alpha with different tone mapping options selected and combine in Affinity Photo.


I don’t do the tonemappings, but I see this too. Reported as RH-61644 Logarithmic tonemapping kills alpha channel.

1 Like

Thanks. I don’t know whether this happens on windows or not. I haven’t anyway of checking.

It happens on Windows. I tested it before logging the bug (:

1 Like

I’ve also discovered the Post Processing ‘fog’ kills the alpha channel too.

And in my latest attempt, the depth channel is useless. It is almost entirely 100% black or 100% white.

I got finally around to look at the file you shared. I have logged

Looks like range of data gets compressed incorrectly somehow. For now as a temporary work-around you could place a plane, or a sphere section, behind your model. That will give you some range with which you can work. Assign it a Physically Based material with Alpha set to 0.0 in the Opacity channel section.

1 Like

Thanks, good to know there is a workaround for now.