Render mesh glitch

My customer send me this example file: Paneelstoffering Voorhut.3dm (1.6 MB)

When he and I zoom out, there’s a render mesh artifact that shouldn’t be there; the render mesh shows untrimmed.
I tried to shrink trimmed surfaces, but that doesn’t help.

Another observation that I mentioned to my client, is the over accurate setting of 0.0001 mm, but that’s not related to this problem.

We’d like to hear what happens and what can be done to avoid this behavior.

Thank you in advance for taking a look.


Hey Gerard - 2 bad surfaces in there… Eliminate those and display goes back to normal… --Mitch

Thanks Mitch!

What surprises me is that I indeed find two bad surfaces. However when I invert selection and hide objects and zoom, I don’t see them. Are these objects some phantom objects?
How were these bad objects created?

Yep, that’s what I call them… Can’t select them directly (only with SelBadObjects) and hard to see them (only from some angles). Sometimes RebuildEdges or Untrim help, this time not… I don’t know exactly what is wrong with them - nor how they got created.


Ah yes.
I also tried to rebuild edges of the visible surfaces, but that didn’t help.

Thanks again

The bad surfaces do not have edges - it would be good to know who these were made - @Gerard , do you know?



OK, that’s why RebuildEdges didn’t work then… :smile:

Yep, nor Untrim - we see these once on a while - not often - so Rhino is making them somehow - I’d love to know what operations do this…