Removing dimensions from one of the viewports only

Is there a way to remove the dimensions from just the perspective view in Rhino for Mac?



But you could:

  • use a custom display mode in your perspective view and disable dimensions
  • move the dimensions to layout space

Thanks wim,

How would I move the dimensions to layout space?



i think the new custom display which wim suggested would suffice.
just disable the show annotations in the custom display mode.
you can alias or shortcut it.

but i would also be interested what he actually means.


Thanks, I’ll give it a try!

In Rhino for Windows there is a separate command for doing that (ChangeSpace) but you can always just cut dimensions or geometry in the modeling space, go to a layout, and paste the stuff there. Just make sure it’s on the world top CPlane first.

Of course, when it comes to dimensions, Rhino is built around adding them on a layout, not in the modeling space. So it would be best to create them there from the start.

Thanks Wim

You could use HideLayersInDetail for this.

Good day Rick,

Not sure if you’ve managed it the meantime…?

I hope this can help you…
There is another option of removing it for a certain Type of view.
So if for instance, you have 3 views in artistic or pen and only perspective in Rendered view.
You could switch off the dimensions in rendered view, even though for the artistic/pen views it will be switched on.

If this can help, you will need to open the Rhino Options menu (the gear icon in the toolbar).
And under View_Display Modes_Rendered_Visibility you can edit what is visible on the rendered views… Now you can switch on and off amongst other things curves, clipping planes, text and then annotations (aka dimensions)…

Kind Regards,
Lilly White

Thanks so much for your suggestion. Your method is what I finally landed on!



I duplicate the “Display Mode” and turn off “Text or Annotations”.
Then I assign each viewport the “Display Mode” as needed.

Thanks very much for your reply!


How do you assign each viewport a different annotation style? Thanks

Hi Jacob -

The picture shows a different display mode (with annotations turned off), not a different annotation style.

1 Like

You were right, it was “display mode” not Dim style, thanks for point it out.

I just edit the post.