Remove Sketchup export warning window

I would like to get rid of this message everityme I export as sketchup file, is it possible?

Hi @Pitti,

Can you provide me a script and a model that repeats this?

– Dale

but the implicite answer is that there is no way to remove that warning?
The resulting skp file works fine.

Hi @Pitti,

Are you scripting the export command by running _-Export...?

– Dale

Yes, this is what I am doing:

    exportSKP = "!_-Export _SaveTextures=_Yes " +  "\"" + blocksExportName +  "\"" + blocksExpString + "_EnterEnd _Delete"

I don’t need to solve the meshing problems, I need to get rid of that warning, because the script needs to continue…
this is the test file:

block fore Dale.3dm (10.4 MB)

Check this YouTrack issue for updates regarding this fix.


thanks @Tim, so no solution at the moment?

Does anybody have another option for exporting blocks preserving instances?

As I recall you can make your geometry large and then scale the block instance to get the right size. It’s the geometry that needs to be larger, the scaling transform (to make it smaller) works ok with SketchUp. That should prevent the warning from happening. The fix I made above was just to write the warning to the command line instead of popping up the message box.

1 Like

Thanks for the suggestion, i will try that.
But my hope is to find this warning Written to command line instead of message box in the next rc :stuck_out_tongue:

RH-61378 is fixed in the latest Service Release Candidate

So it’s fixed in rhino 7?

Hi -

That’s correct, yes.

1 Like

and I guess the same fix is not expected for rhino 6?

Hi -

That’s also correct, yes.