Registering plugin problem

unhandled

(Andrew) #1

I am registering our net.commons plugin programmatically, by making the usual registry entries at:

HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0\Plug-ins<your_plugin_guid>`

This works OK, except that the plugin isn’t enabled… this means that on every Rhino 6 start the user is asked if they want to load this plugin.

Is there a setting that I can add to avoid this?


(Andrew) #2

Well I didn’t get any suggestions, so perhaps I didn’t describe the problem well enough. Here is another try:

We install plugins for Rhino 4, 5 and now 6 the same way.
Programmatically we add registry entries of:

HKLM\SOFTWARE\McNeel\Rhinoceros\6.0\Plug-ins\our_guid\Name
HKLM\SOFTWARE\McNeel\Rhinoceros\6.0\Plug-ins\our_guid\FileName
HKLM\SOFTWARE\McNeel\Rhinoceros\6.0\Plug-ins\our_guid\FolderName

This works ok for Rhino 4 and 5.

For Rhino 6 the plugin is registered, and on first time use the registry enties are populated in the HKCR registry.

But the plugin shows up in the installed plugin’s list like this:

You can see that the our plugin MeliarComR is not enabled.

Because of this every time Rhino 6 starts the user is asked:

image

Is there a setting that I can add to the registry that will make the plugin load and be enabled normally?


(Nathan 'jesterKing' Letwory) #3

@brian, @stevebaer - something for one of you?


(Steve Baer) #4

Can you send me your plugin so I can try to repeat this? It may be a bug in Rhino that needs to be fixed.


(Andrew) #5

Thanks.

I doubt that the problem is with the plugin, if I install it by hand it all works ok.

I suspect that problem is with my installer.

I could send you:

a) a copy of the plugin
b) a copy of the installer, that contains the plugin
c) a copy of one of our program installations, that contains the plugin installer

let me know where to send it to, like an email address.


(Steve Baer) #6

steve@mcneel.com - just send me the plugin and I’ll see if I can determine what is happening. Thanks


(Steve Baer) #7

Hi Andrew,
I haven’t been able to repeat the problem with your plug-in. I created a key in regedit at

HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\6.0\Plug-ins\112f133a-8afd-4656-b04a-d313a05800e5

And created a string entry named FileName with a value of C:\Users\Steve\Downloads\MeliarComR6.dll

When I start Rhino the plug-in is installed the first time and then on subsequent restarts the plug-in is just there and works as expected.

Anything you can see in my test that doesn’t match what you have tried?


(Andrew) #8

My apologies, I was looking for a reply by email and missed this post.

Thanks for trying the plug in for me, unfortunately on my computer it is defiantly showing to be disabled on a rhino restart.

And let me correct a false statement that I made at the beginning of this thread:

If I install the plugin by hand, using the install button on the rhino… options… plugins screen, it appears to install ok. But on subsequent restarts the plugin is not enabled, and the load warning screen shows.

So now I don’t think it’s related to the plugin registration, I think it’s something I’m doing wrong in the dll.

Any pointers??