Record History sees only some aligned dimensions update as item moves

I have set record history to always then placed aligned dimensions between rudder sections and tailfin skin in top view to assess gap.
Nudging rudder to e.g. stbd sees most of the dimensions update but not all, I have redone a few, one of which now updates. I cannot get some to update, yet zoomed right in, for checking placement, even tried Ctrl osnap onCrv for one end, also tried for both ends of dim.

I look to see wher dim arrow tip is and it is where I last placed it, its not ‘attached’ to the rudder, what influences if it becomes attached or not ?

I am recreating the bad ones in perspective view to be sure I am on target.

Any help welcome.


The dimension points have to be placed using osnap for history to update them. Otherwise, they don’t know what geometry they relate to.
Or you can turn on the dimension points and move them along with the geometry.

Where is Osnap for History to be found ?..if you mean that as a command ?

I was using Osnap to place them, using Int and end

[quote=“lowell, post:2, topic:21398”]
move them along with the geometry.
[/quote] not sure I follow you there, f10 then 'move them along with geometry ’ ?

What I have found is that with Record History set permanently on during their placement , some failed. If I then turn it of, then on only for each dimension, allowing it to turn itself off after each dim is placed, each one works.



Steve, as always, if you post a file there is a chance we can help. Include a dim that works, one that does not.


That’s what I meant you should do.


Pascal, just a FWIW, I was able to get one dimension to not update but wasn’t able to consistently reproduce this.

I’ve also created a related bug RH-30648 that is assigned to @lowell.


here is a sample of the issue, I have in fact redone these dims and not one will now update, I only had some misbehaving on the original item, some ( right hand set in ortho front) were done with RecordHistory permanently switched on, others with it running for one dimension placement, then it expires !

Nudge the semicircles to the right in ortho view Front and the dims dont change.

For some reason they dont ‘bond’ to the line ends .
RecordHistoryFailUpdateDims.3dm (748.3 KB)

In your model, the lower 2 dimensions on the right have history records and the rest don’t.
You can see in the What listing, at the bottom, if an object has history or not.
The 2 with history records update as expected here.
No way to tell why the others don’t have history records at this point.
I tried placing a few dimensions on your curves and it worked as expected.
If you can find any pattern with how you make the dimensions that causes the problem, we might be able to fix it.
In general, editing objects with history breaks the history connection, but there are some edits that don’t, like changing dimstyle, etc. You would be notified of any break though.
Pretty inconclusive - I don’t know where to go next

I religiously had record history on, then selected dimension aligned, , placed the dimension ends,a dn location of the middle point, then rec history closed.

those down the right had rec history set to permanently on, during their placement.


My guess of the moment is that at least one of the dim points was not on a snap point.


Hi, I had int snaps happen to all though.


Ah, ok - so we may be on to something … Int hits and, I am guessing a bit here - records the parameter on one of the curves involved if history is used - so the dims will follow one curve if it is moved, but not the other. So it does not stick to the intersection but to the location, on one curve, where the intersection was when the dim was placed. @lowell, is that what is happening with Int , more or less?

It still does not explain the lack of history on your dims, only why moving some objects might seem to ignore history.


Hi, ah…second thoughts it was int on the semicircle intersecting with the line coming from its centre, and END on the tip of the line the dimension is to.

I used the same procedure on all of them, in the original where I noticed the problem , then when I nudged the semicircles, some but not all dim numbers changed.

This one, same method, no dims update. or hardly any.

I dont suppose end then int as opposed to doing int then end makes any difference ?

I may have gone int end each time, wouldnt like to swear to it though.


If you use int, and the objects which created the intersection have changed, that might kill the history.

For example, create two rectangles that intersect. Create a dimension that snaps to the intersection of the two. Now fillet one corner of one of the rectangles. Then move one of the rectangles slightly - the dimension will not update, history has been broken. You will see a message “History failed to update one object” in the command line.


I didnt see a history broken message.
Steps were:-
o. turn on Record History all time on.

  1. select aligned dim and click on intersection of curve and line,
  2. click on end of line
  3. place dimension

repeated for the other dims required.

4 turn off rec hist.

nudge the circle and some dims changed, some didnt.

redid those that didnt with the one shot rec history, then they worked.
nothing done to break history, I wanted to see at what position the dim values became equal at port and stbd.