Raytraced ViewCaptureToFile Crash

had a viewport in Raytraced mode, and tried “ViewCaptureToFile” on it - it popped up a little “rendering viewport” progress bar and then crashed Rhino when it finished. :frowning:

With what WIP version does that happen?


Your WIP is already over 2 weeks old. I have made quite a few fixes for cases like that since that build.


Thanks @nathanletwory - I updated and it no longer crashes… but now raytraced does not work at all, just goes straight to black as soon as I enable it.

hmmm… created a new file and now it’s working again. very odd

(sorry for the barrage of posts) - ViewCaptureToFile in Raytraced is not working with anything but the current viewport resolution - it shows the progress bar and saves successfully, but the resulting image is totally blank.

viewport resolution:

scaled to diff. resolution:

@rajaa, can you take a look? AFAIK I haven’t changed my side of the code…


@andheum Can you please try the next WIP and let us know if you still have a problem? We made some changes. If the problem persists, please share the file, and the resolutions you used.

I am using the latest WIP version as of today - No crashes, but if I try to capture a viewport using anything other than the native resolution I get an empty capture.

(6.0.16264.10331, 20-09-16)

Just tried in the latest WIP - no crashes, but still doesn’t work - it says “successfully saved” (and takes 0 time) and the file it claims to have saved doesn’t exist.

hmm. Just tried. I get the img saved out.

Work In Progress
(6.0.16278.10551, 10/4/2016)

well, I’m stumped - it seems to work now!

if I can create more reproducible conditions when it fails I’ll let you know.

Having a ‘Cancel’ button on that would be nice.

Though there is an open question as to whether the progress bar should exist at all: https://mcneel.myjetbrains.com/youtrack/issue/RH-34659#