Raytraced view port is lagging as hell

Hello there, I am runnig rhino7 on my system. the raytracing view port is laggy as hell like 5 frames per second.

I have a top end GPU(AMD6900XT) which works fine with other aplications all drivers are uptodate but when it comes to raytraced view it becomes impossible to use.

its not someting ı care about a lot.I just wanted to point it out so it can be fixed. Thanks

Well actual brute force raytracing is insanely, exponentially more demanding than any other display method, it’s going to be "laggy"on God’s own GPU.

Maybe you are right but ı remmember it was running more smoothly on my old GTX770.

Well I don’t even know how good the AMD support is currently.

I went for a ride in my car the other day, and through the front window the graphics was superb. Raytraced mode, Super high resolution, realtime rendering with absolutely no lag.

Only thing slowing it down would be a black hole. :wink:

// Rolf

In Rhino V7 Options > Cycles, on the OpenCL tab, are there any available GPU resources shown?

I have a Quadro P2000 so I have CUDA GPU resources:

But to you, traveling near the speed of light, would not be aware of relative time slowing down.

I have tried it with both CPU and GPU selected roughly same performance

If it’s a desktop, replace it with an Nvidia RTX with lots of CUDA cores and VRAM.

Depending on size of viewport and complexity of scene 5 samples per second may be quite fast.

If you are on latest Service Release Candidate you can play with viewport responsiveness and sharpness setting in the Tools > Options > Cycles dialog.