Hi there,

I wish to render some objects with the new monochrome with some sharp shadows in rhino8. Since the shadows are not rendered that accurately I hoped to achieve this simply by turning on raytraced in this mode.

But combining the new “monochrome” display mode in combination with cycles raytraced doesn’t seem to work.

When I turn on the realtime display engine to “cycles” in the settings, it’s not rendering hard shadows like it does with the standard “raytraced” display mode.

monochrome with cycles:

monochrome without cycles:

Raytraced mode:

@nathanletwory Do you have any idea why I’m not getting the desired results when I combine monochrome with cycles?

Thanks in advance

Rhino 8 SR1 2023-11-21 (Rhino 8, 8.1.23325.13001, Git hash:master @ 8a4a437248efac5d9cb04d3904481b83e4c23a64)
License type: Evaluation, build 2023-11-21
License details: Stand-Alone
Expires on: 2024-01-30

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64Gb)
.NET 7.0.14

Computer platform: LAPTOP  - Plugged in [77% battery remaining]

Non-hybrid graphics configuration.
  Primary display and OpenGL: NVIDIA GeForce RTX 3080 Laptop GPU (NVidia) Memory: 16GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port
  Primary OpenGL: NVIDIA GeForce RTX 3080 Laptop GPU (NVidia) Memory: 16GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port

Secondary graphics devices.
  Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
    > Integrated graphics device with 4 adapter port(s)
        - There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 10-26-2023
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino
  C:\Users\MaximeSellingZJANL\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\D5Conv (e0d5e210-02f6-4ee9-a2b0-1675e225d958)\\Rhino 7\D5Conv.rhp	"D5Converter for Rhino"	
  C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp	"Datasmith Exporter"
  C:\Program Files\Rhino 7\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp	"Karamba3DLicense"	
  C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp	"V-Ray for Rhino"	

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 8\Plug-ins\Commands.rhp	"Commands"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp	"WebBrowser"	
  C:\Program Files\Rhino 8\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp	"AnimationTools"	
  C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp	"MeshCommands"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.1.23325.13001
  C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp	"SectionTools"

Hi Maxime -

The Monochrome display mode is based on the technical display pipeline, and those cannot be combined with the regular display modes.

Thank you @wim,

Are there any plans in the future to make this combination available?

And do you have any idea why the sharp shadows in monochrome are inaccurate and what I could do to improve this?


Hi -

I know there is an intention to get rid of the special technical display pipeline by incorporating the features in the regular display modes but there are no concrete plans at this point.

It looks like you could change some shadow settings to make those more sharp and accurate:

I didn’t play with this much… These are the settings that were changed to get that picture:


Hi Wim,

Thank you,

I’m using those settings, but for some reason the shadows aren’t aligning with the geometry. There is always a little offset on the edges.

You can also try some of the following custom display modes that I uploaded in another topic recently, as well as to modify the edge settings if you wish so. They all offer a substantially better performance than the “Monochrome” display mode, especially if it has sharper shadows.

Чертеж 5.ini (12.7 KB)

Toon.ini (12.7 KB)

Toon transparent.ini (12.8 KB)

@wim , I tried your shadow settings for the “Monochrome” display mode, but seems like they want to kill my Nvidia GTX 1660 Ti 6GB. :smiley: After I set those shadows the way you recommend, the framerate is about 1 frame per second or lower.

1 Like

Hi Maxime -

I suppose that means it’s the “Soft Edge Quality / Speed” setting that influences that behavior.

I don’t recall having recommended anything.

A user asks for an advice and you post settings that work in your sample image. Seems like a recommendation to me. Or call it an advice, or shared thoughts, or opinion from a developer. :slight_smile: Same end result with the intention to help the user.

Those settings don’t show any difference in my Rhino 8 BETA, except that the framerate gets below 1 fps. :smiley: No matter the settings, I can’t make the shadows sharp.

Thanks! this solved it.
@Rhino_Bulgaria thank you as well for your custom settings. Looks great

1 Like