R8 Toolbar file and EditImage dialog issues

Hi @stevebaer,

yesterday i was trying to port some ToolBars from Rhino 7 to Rhino 8 and ran into some strange issues. I’ve started creating a new rui file like below:

  1. From Options > ToolBars i’ve chosen File > New
  2. In the RUI file to create dialog, i’ve entered my rui file name “MyTestFile.rui”
  3. saved “MyTestFile.rui” on my desktop
  4. added one new ToolBar using *Edit > New ToolBar, named it “MyToolBar”
  5. added some new ToolBar buttons using 64x64px svg icons created in Illustrator
  6. saved the rui file using File > Save MyTestFile
  7. Closed and reopened Rhino 8 to see if my changes stick

So far this worked out OK, so i closed R8 and then did this:

  1. Renamed “MyTestFile.rui” on my desktop to “Custom_V8.rui”
  2. Opened Rhino 8 and got an empty container without any ToolBar in it (?)
  3. Found out that “MyTestFile.rui” got somehow re-created on my desktop (?)
  4. While the “Custom_V8.rui” file was still there (?)
  5. I opened “Custom_V8.rui” and the contend thankfully was intact

Is this expected ?

While i was using the Edit Image dialog, i was running into some issues:

  1. I’ve created this svg file using Rhino 8: RPS_Icon.zip (2.6 KB)
  2. Tried to open it in the Edit Image dialog, which crashed
  3. Somehow managed to get it into that dialog but it causes a long timeout on load
  4. I was not able to use Edit > Clear unless i closed and reopened the dialog

Since i encountered more crashes and very long timeouts importing several svg files, either created on my own using R7, R8, Illustrator or downloaded online i tried to draw something in the Edit Image dialog myself. This turned out like below:


It seems that the tools provided (pencil, line, rectangle, circle) sometimes did not start drawing where i clicked my mouse. There was an offset but not always. The worsest behaviour i got when trying to draw a filled circle:


It seems that sometimes the circle is not drawn while the mouse is moved or released.

So after trying to port my stuff to R8 for a few hours, i gave up. I feel scared, in the last 2 decades i’ve created over 200 pretty button images und published rui files to my clients. Is there i way to get them in R8 without sending them old R7 rui files at all ?

Why are images not allowed to be imported or pasted into the Edit Image dialog ? I mean i can simply create an svg file in Illustrator, paste my image there and then import that svg file into the Edit Image dialog. It seems a less productive workflow to me. Some image contents like gradients cannot be re-created quickly using vector based files. I really would like to re-use what i allready have created in all these years.

Using the new button creation wizard i’ve found some issues: I’ve clicked on the Add button to start the button creation wizard which brings up this dialog:

next, chose “New Command”, added some text details tried to add an example icon to it, which caused a freeze of the Edit Image dialog. Here is that icon:

Splash.zip (3.7 KB)

While i was waiting for the dialog to come back, i’ve noticed that it is not kept on top:


After 15 minutes i gave up and closed R8. Then reopened it to use another svg for the left button command which i know imports in a second:

If i then choose Next in the wizard i’m asked for the right button command where i choose “New Command”:

This brings up the dialog to enter the command details again but the left button image i’ve chosen before does not show up here:

Is this intended ? I mean there can only be one image per button (the button i am about to create) or not ?

One last question: When i create a ToolBar, i get a smaller icon in the ToolBar tab, left from the ToolBar title text. In R7 it was possible to define an icon for that. In R8 it seems not to be possible. Instead it uses a downsized version of the first button:


How can i disable that smaller icon or control which icon is used ?


Yes, I would say so… Right now, saving a .rui is pretty broken - see some of my other posts about it. Also, some stuff concerning changes you made in the ,rui are actually not saved in the .rui itself, but rather elsewhere in the settings files.

Yes, I have experienced this. You can’t really work with the editor in its current state. I have made my SVGs in Rhino, but it’s somewhat limited as well. Basically only curves and solid hatches are possible.

I’ve spent several weeks now.

Here it opened instantly, no freeze.

This is a problem with a number of the dialogs, not just this one.

Yes, that would be good to know.

@brian or @Gijs can you help record the issues here?

@stevebaer yes, I’ll test and log

1 Like

As for this issue, I see the same behavior in Rhino 7. Were you expecting Rhino to know that you changed the name of the RUI file?

The icon you try to paste is huge, and I can confirm the freeze here.
RH-79884 Importing or pasting SVG takes a long time or hangs Rhino

See if this template helps (here pasting the reduced size pastes instantly:
icon-template.ai (342.5 KB)
The attached smaller icon should also load instantly:

Yes, as you can see this new command gets associated with a Macro. Should you want to use that macro again, it will be associated with its own icon. (See _Macros)

You can right click the tab and choose properties, then set the icon there:

But there seems to be a refresh issue.

not automatically, but I linked a tool in this YT:
RH-78590 Auto convert pixel based icons to svg

The current icon editor is embarrassing, to say the least. The behavior is a bit better on Mac than on Windows, but even so it lacks features that the old editor had.
For now I recommend creating the icons in Rhino/illustrator, with the provided template. Copy linework from Rhino to illustrator, scale the linework to the provided template and then either save to svg, or paste it from illustrator into the icon editor.

flickering ellipse tool:
RH-76210 Ellipse tool in Icon editor flickers

Hi @Gijs, not at all. I where expecting that R8 just cannot open the rui file and will not show me an empty container with the old name. I’ve closed the rui and R8 before i renamed the file on my desktop.

btw. the RPS icon was saved with Rhino as svg, using 64x64 pixel width. I still see either complete freezes or lockups opening svg files. If the files come from Illustrator the seem to work.

No. This whole connection to macros is extra confusing for users. Note what the dialog says in the title:

I cannot see any change here, it seems to clear out the old icon but does not show the chosen one.

btw. after i’ve now took the time again to build a toolbar i’ve saved it from

Options > Toolbars > File > Save...

then closed R8. Once i reopened R8 i found that 3 buttons are missing, the last button i added is now the first button in the toolbar. Seperators are either missing or do appear between buttons which i have not placed them.

I hope i do not sound too disgruntled but the current state is that i cannot re-use what was there, i cannot re-create new things from scratch nor can i store things i manage to create. It just scares me that i cannot publish rui files without knowing how they will appear on the client’s side.

If i click on your link icon-template.ai it downloads a pdf file. If i open that in my old Illustrator (it asks for conversion) i can copy it. Once in R8 i cannot paste it. Trying to paste from the menu shows me that the entry to paste is grayed:


Omg, new observation: If you change the image from the Container Properties dialog, it will just clear the small icon left to the ToolBar title. Once you reopen R8, this chosen image is now the image of the first ToolBar button, and the first button which was there before is now just gone.

I’ve now tried to delete that first button which failed. Deleting a button brings up this dialog:


After clicking OK, the button i am trying to delete is sometimes deleted sometimes not. In below gif i’m trying to delete those buttons where R8 somehow forgot the icons i’ve set to them. It also forgot the command and all other text fields like tooltips etc.



@clement can you send me the result of _SystemInfo?

The behavior you are experiencing is… expected. Part of the information about your new toolbar is stored in the .rui, part of it is stored in your settings files. And the container that contains the toolbar is stored in yet another file in settings. So that’s three places where info is stored to construct your toolbar.

If Rhino can’t load the .rui because you changed the name, it will still load the container, but of course it will be empty…

Dunno, the rps.zip I downloaded from your post above comes into Rhino as 4562.376 printer points square (first time I’ve seen a file come in with points as units) and that translates to 63.36 inches (72 points to the inch) - so maybe the file was 64 x 64 inches?

As an aside, I imported some of the original native .svg’s into Rhino and they all seem to be 48 x 48. So I ended up making my own template for .svg’s at 48x48.
SVGIcon.3dm (2.1 MB)
Your “splash” icon opens as 64 x 64 (millimeters) in Rhino and it loads fine here in the button editor.

Yes. Reported multiple times, as recently as this weekend - saving an .rui is completely broken currently.

Yep, I would not distribute anything concerning toolbars to anyone else right now.

Don’t ask me how I figured this out, but the attached template seems to work.
icon-template.3dm (113.7 KB)

At least here it outputs SVG files with nice numbers:
<svg version="1.1" width="96pt" height="96pt" viewBox="0 0 96 96" overflow="visible" xmlns="http://www.w3.org/2000/svg">

and loads without issues in the Image Editor.

48 x 48 picas ? Even more fun than points… :stuck_out_tongue_winking_eye:
(12 points to the pica)

What’s all this stuff on the “margins” layer? (OK, I understand the 1 unit outer margin)

Yeah those layers are just for reference.
Important is how the print window is set up and the output is 34 x 34 mm
The fact that there is a margin is also a bug, and has been logged.

RH-79892 Drawing behavior in Icon editor when Pen width is not 2

Not visible to public…

Not 48 x 48 ? In any case I exported all of my .svg’s as 48 x 48 (from my template posted above) and they all load fine in the image editor and look fine on the buttons.

The print dialog is currently annoying because each new session reverts to “Viewport” and thus some random “scaled to fit” value, I have to reset it to “Extents” and 1:1 every time.


Actually I’m not seeing any of the problems you mentioned in the YT item here in the Windows Rhino 8.4 image editor.

Tested in 9.0.24020.12005 ??

no, for some reason, exporting it to 34 x 34 mm turns out to result in a 96 x 96 SVG.

It’s more for convenience, so I can run two different build dates (installing older builds on Windows is cumbersome), and that build is more or less the same as current 8.x branch. The bug is also present in 8.4.24020.1001 btw

that was a left over of things I tried, the units setting doesn’t seem to have any influence on the SVG output. I modified the template file linked above.

Indeed. Seems these settings are not stored when saving the Rhino file.
RH-79899 Export to SVG /print settings are not stored correctly when saving.

Something is wonky there:

But 1 pica is 1/6 of an inch, so 1" = 6 picas is scale 1:1

If I try to duplicate your settings I see this:

Anyway, I’m going to continue to use 48 x 48 here because that’s how the standard Rhino .svg’s open here, I can open them and modify them (limited) and then re-export.