Python Script works in Rhino, doesn´t work in Grasshopper

I have achieved a shape in Rhino using Rhino Python Editor. I want to achieve the same shape using the same script in Grasshopper, however, it doesn´t work as intended. I´ve tried debugging the entire code and found out that it does in effect go through every step of the process, as you will see in the panel logs, but for some reason, the lines that I need to be drawn are not.

I have uploaded two screenshots: the one with the shape I need and the one with the shape I´m getting in Grasshopper. I´ve also uploaded the script I used in Rhino in a .txt file and the grasshopper file
. When you open Grasshopper you´ll see a GhPython component with the script adapted to it. Thanks in advance,

Pablo Mora

Grasshopper File:

181104_Gh Python no (67.8 KB)

Original Script from Rhino Script Editor:

181104_Original Rhinoceros Python (1.3 KB)

How I want it to look:

How it looks:

Hi Pmora
I hope this help you.

181104_Gh Python no lines .gh (64.6 KB)

Thanks Naruto, it worked!