Purging "stuck" third-party materials

Attached below is a part of a student file. The object (actually a group of objects) in it has been downloaded from the 'net somewhere and at least one of the objects in the group seems to have come with a V-Ray material attached to it. The student is using Mac Rhino.

If I open the file - keeping the one “woodgrain” material that the student applied to the object in the folder with it so it can be found by Mac Rhino again - and set the renderer to Toucan, then launch a render window, the object renders white. It does so no matter what material is applied to it. With Rhino render, it’s OK.

I have tried all sorts of ways inside Mac Rhino to get at the underlying stuck material and dump it so it renders properly in Toucan, but to no avail. The only thing that worked: -Export the object with SavePlugInData unchecked, then re-import. Unfortunately there’s a file full of these things. I thought I could -SaveAs and uncheck SavePlugInData, but although -SaveAs does seem to save the file, the plug-in data is still there afterward.

Anyway, we’ve worked around it for now, but shouldn’t there be something like a “PurgeAllMaterials” command for completely scrubbing materials from objects? I tried Matching the object to a box with default material applied, that didn’t help.


DeskExample.zip (243.6 KB)

@marlin is making all sorts of changes right now to rendering and materials, so I’m filing this bug just to make sure that we test the behavior once things have settled down (MR-1077).