Pull Point function

hi all ,

am trying to pull the points to the curve and
the distance still not changing to 0.0 after pulling the point
see the snap shot for details

is there any alternative way to pull the points to curve so the distance become 0.0


pull point not working.gh (12.1 KB)

It looks like what you really want may be “equal (to zero) within tolerance”?

As an alternative, you could try Curve CP but it seems to give the same results. Most likely the answer is what @Joseph_Oster has already posted, closest point within given tolerance.

Which brings me to the following question:
Is this how Curve CP is supposed to work? I thought the output point was always ‘on’ the given curve (irrespective of tolerance) since that is what it mentions on the component as well

It starts getting a bit scary when I use Evaluate Curve on this example, and I am still not getting a zero distance output:

After reparameterizing the curve, the distance goes down a lot, but is still not zero:

thank you @Joseph_Oster

Thankyou @technostark
is there any script or any application to figure it out

Not that I know of, but for all practical purposes, I doubt that an 11th decimal place is going to cause any significant problems in your work.

All said and done, it really shouldn’t happen (at least the way I understand it!). And I can’t say why it is happening, unless it’s a bug