Our list of issues with R6


Since upgrading to R6, we have really struggled with a catalogue of issues. Sorry to dump them all into one thread, but it seems the simplest way to get it all out.

We will probably revert to R5 at this point as it was running quite happily and the issues with R6 seem insurmountable in its current iteration. It will be a shame to lose the advances in make2d, but this is one of the features that hasn’t been functioning properly for us anyway, so no great loss.

One of our main bugbears was with Boxedit being completely unreliable, and I know that this is being worked on for the next SR (thanks Pascal) but this is just one of many problems.

Here is the list we’ve made in our studio during the couple of months we’ve used R6:

1 - Linear dimensions become invisible changing views, user must highlight/select them to make them visible again.

2 - Strange behaviour of highlighted objects - sometimes bold yellow, sometimes subtle yellow leaving us unsure if the item is highlighted or not.

3 - Make 2d is unreliable. Sometimes it fails completely (but without an error message in the command bar) sometimes it fails to produce a view when using 1st or 3rd angle projection.

4 - Planar linear dimensions do not always snap correctly (unable to snap to points when clearly visible)

5 - Make 2D is far slower than it used to be (not a major issue, but seems like a step backward)

6 - when dragging object, we receive the error message ‘history was broken on object’. there is no way to switch this alert off, and it costs us about 1000 extra mouse clicks a day.

7 - Dimensions no longer auto update when changing the c-plane in perspective mode - in R5 you could change cplane without ending linear dimension command - in R6 you cannot.

8 - Box edit tool not showing accurate information rendering - File removed
it useless.

9 - in plan curves/dimensions will become invisible randomly without warning - the only solution we’ve found to this problem is to select all geometry including 2d drawings and dimensions and move up, then down again. this seems to make things reappear. however, when rhino checks the history of the dimensions, this can take minutes.

10 - Using Cutepdf writer (which was fine in R5) Print to PDF doesn’t work every now and then, produces blank document.

11 - When moving a drawing around, it checks every single dimension for breaks in the history, this slows down things considerably

12 - Zoom window works normally but seems to de-focus on whatever it was focused on (selected region for rotated focus will change to random background)

13 - When dragging 2d drawings with dimensions, the values of the dimensions change. this is a huge problem for us, and I can’t think how it would even be possible.

14 - when selecting a linear dimension its size isn’t shown correctly in the object properties tab.

15 - I have no evidence for this, but it seems that my computer is having to work a lot harder to run R6 than it did with R5. More hanging, mouse lag etc.

I appreciate that some of these problems might be intentional behaviour by R6 that we’re unaware of and simply perceive as problems!

All of these issues should be apparent in the attached model, though these issues are all apparent in every file we’ve created in R6.

It would be great to know if there is a plan to work on these issues. It seems such a shame that R6 hasn’t been able to incorporate successfully all of the features of R5 that worked so well.

Also, can anyone tell us what our options are in terms of reverting to R5? is there a way that our R6 files can be transferred or are they now R6 for ever?

Many thanks,


1 Like

Hi John - thanks, I’ll take a look at your list and try to give more detailed answers but a couple of things, quickly

  • can you run the SystemInfo command in Rhino and paste the results here?
  • You can SaveAs any file from V6 to any previous Rhino/3dm version.
  • You can get the SR11 build by changing Options > Updates and Statistics > Update frequency to ‘Service release candidate’. Some of the display problems may be fixed there.


Hi Pascal, many thanks for your reply. here’s my system info.

That’s very helpful re. saving to R5.


Rhino 6 SR11 2018-12-4 (Rhino 6, 6.11.18338.9511, Git hash:master @ a3049ebfa764d855baca55e731f38f5951ece9ac)
Licence type: Commercial, build 2018-12-04
License details: Cloud Zoo. In use by: john ()

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: JOHN-PC

GeForce GTX 750 Ti/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 353.06)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-27-2015
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18338.9511
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18338.9511
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18338.9511
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18338.9511
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi John - I think at least some of the display related stuff will get better of you get the most recent driver from the NVidia website. (don’t believe Windows if it tells you the driver is up to date.)

@john11 - you can get a build of SR12 from here:
The developer tells me there are more display related fixes there that may help.


Many thanks Pascal,

I’ll try updating the drivers and get the latest build and let you know how we get on.

Most of the issues are minor annoyances. The ones that are serious for us are the ones where dims are changing (ie. no. 13) as this could lead to costly mistakes in our workshop. Any ideas why these are happening?



Hi John - do you mean you drag a detail view within a layout and the dims change values? I imagine History is involved - I’ll try to reproduce this. From your comments, it sounds like maybe shutting off history altogether for annotations might make your life a little calmer - this can be done via the History command > RecordAnnotationHistory=Yes/No. To remove history from existing dimensions use

! SelNone SelDim HistoryPurge

Any of that help?


Hi Pascal,

Not at the computer now, but if you open the file I uploaded - in plan view, select the 2d drawings and drag using gumball, the values in the dimensions change! This isn’t in a layout tab, but in model space.

I’ll come back to you when I’ve had a chance to test your suggestions.

Thanks again,


Hi John - many of the curves in the 2d drawings have dimensions with History on - so, depending on what you move, dimensions could well change - if you move all the objects that are being dimensioned by a particular dimension together, the value should not change though. (So far, I am either doing it wrong, or mis understand what you mean, or it is fixed, but I do not see anything unexpected - still poking)


Hi Pascal,

Its when we drag the curves and dimensions together. have a look at this video (apologies, shot with my phone).


Quick question,

if I download and install the linked version of SR12, will all our templates/toolbars etc be retained?

many thanks,


Hi Pascal,

Have you had a chance to look at the video I uploaded?



Hi John - I see that - it is alarming … I’m testing now…
I cannot reproduce this so far - @john11 - is that clip using your SR12 release?
It looks to me like the lower leg of that dimension is jumping off of the center of the little circle -

I can reproduce this in your file.


Hi Pascal,

I haven’t had a chance to install the SR12, will let you know if I can reproduce once I have.

Its a weird one!


Hi John - I can reproduce it here with your file. Also, I just sent you a PM that you should look at - just in case,.


Hi Pascal,

Now running SR12 with updated graphics card drivers.

Box edit seems to be fixed which is great news.

The first thing I’ve noticed that still isn’t working great is the dimensions - these are disappearing until highlighted. still in the same model as I linked earlier.

Thanks for your help.


here’s a vid of the disappearing dims

By the way, we also still have non-functioning make 2d. sometimes nothing happens when we run the command.


Here is an example file that shows the non-functioning of Make2D when attempting a 4 view projection. I can’t generate first or third angle projections of any of this geometry successfully.

Any ideas?

John.make2d errors.3dm (5.6 MB)

Hi John - are you saying that you select all this stuff, Make2D and nothing happens at all? Does it even go through the motions (Command line feedback will tell you) Are any layers added? DoesZoom Extents show you results that are in a weird place, perhaps? It works here so far - 1st and 3rd angle projection, View and Cplane…


Hi Pascal, thanks for coming back.

So the first item from the left works fine for me (the one with the two cutouts).

From then on they don’t work. There is some action in the status bar at the bottom of the window, but nothing happens.

The command line looks like this:

Command: '_Zoom
Drag a window to zoom ( All Dynamic Extents Factor In Out Selected Target 1To1 ): _Target
Select new camera target
Drag a window to zoom
Command: _ProjectToCPlane
Delete input objects? ( No Yes )
1 polysurface added to selection.
Command: _Make2D
1 polysurface added to selection.
Command: _Make2D