Problems exporting to DWG?

Hi,

I am trying to export my 3D model to a DWG (2004 solids in the export settings), and despite my model seemingly being clean with no bad surfaces etc, many objects in my export come out like below, with rectangular surfaces above and below the object. The screenshot shows just a single exported objected.

I was wondering if anyone knows why this might be happening?

Thanks

Hi Sam -
I tried with a simple object and the 2004 Solids scheme in Rhino 5 but didn’t get such untrimmed caps.
Could you post an example file?
-wim

Hi Wim,

I’ve attached a .3dm and a DWG export containing one of the troublesome objects.

Thanks

01_Problematic Object.3dm (830.7 KB) 01_Problematic Object.dwg (80.5 KB)

sorry - i exported the dwg as ‘‘default’’ by mistake for the previous attachment, new copy attached as a 2004 solids export. 01_Problematic Object.dwg (90.3 KB)

Hi Sam - Thanks, I see that here with the file that you posted.
This is a “far-from-origin” issue that you can work around by changing your document units from millimeters to meters.
HTH,
-wim

Hi Wim,

Thanks, I’ve realized that the issue may be related to importing the dwg rather than exporting. The original export opens fine in DWG trueview.

I’ve also experienced this issue frequently when importing DWGs which have been exported by various other consultants on my project team (landscaping etc). I’ve tried changing my file from mm to m prior to importing but i’m still having the same error - a pop-up informing me than ‘‘An Invalid polysurface was read. Would you like to salvage as much as possible of invalid polsurfaces?’’. The same models open fine in DWG trueview.

The result is a context model in rhino which has many strange rectangular caps over various objects. Unfortunately as we’re using geolocated models, our origins are often extremely far away.

Is there anything that can be done to work around this? I am finding myself often unable to import DWGs from other consultants into rhino.

Thanks

Hi Sam - this may help -

https://wiki.mcneel.com/rhino/farfromorigin

-Pascal