Problem with unrolling surface


#1

Hi there,
I am getting very weird undefined edges while unrolling surface.
Please see attached file with an example, thanks.
P.S.
I was trying to upload the 3dm file using the forum but with no luck as I was getting an error (Sorry, there was an error uploading that file. Please try again.).

http://www.filedropper.com/surface


<div style=font-size:9px;font-family:Arial, Helvetica, sans-serif;width:127px;font-color:#44a854;> upload files online


(Pascal Golay) #2

Hi Matt- I see it, thanks. For now please try:

  1. ShrinkTrimmedSrf
  2. UntrimAll with KeepTrimObjects=Yes (need to post-select to see this option)
  3. UnrollSrf, and choose the curves left by UntrimAll as the curves to unroll.
  4. Retrim the result with the unrolled curves.

( We’re working on the uploading problem- sorry about that.)

-Pascal


#3

Thank you Pascal, that worked like a charm.
If that is a bug in the software maybe this will help if I explain how that surface was created, I use different method to create surface for my purpose but I took over this file from my colleague and he used command ExtrudeCrv with series of circles BooleanUnion together. I usually Pipe a curve and then use intersection to split it to get the right shape and have never experienced any difficulties with it - rarely use extrude curve for other purposes.

Thanks a lot,
m@


#4

Matt,
I downloaded your surface file and it unrolled perfectly for me just using unroll. None of the jagged squiggly edges present in the final unrolled surface.


#5

@carvecream
Thanks, I think there must be something wrong with my Rhino then, probably I should reinstall it and check it again.
m@


#6

@matt doh!! it was a units/tolerance issue. (mantra: always check your units/tolerance settings!!) The first time I checked this yesterday I had imported the file into one of my own files with proper tolerance. Today I opened your file directly and you have meters as units with only .01 set for absolute tolerance. Setting it to my standard .001 is what fixes the jagged edges.


#7

@carvecream a good find, thank you! As I said I get the file from my colleague and first thing I should have done was to set the units - that is a good habit!
Thanks again :wink:
m@