Problem with Save/Replace with Rhino 5 for mac

I seem to have come upon a bug as I saved a new file using the name of an existing file in order to replace it. Rhino went to sleep showing the spinning wheel curser, and I had to restart the mac to force the (non-responding) program to close. After restart the file turned out to have been save correctly.

Hi @magisk-
I’m glad the file actually saved correctly, but it sounds like odd behavior. I just tried to replicate this on my computer using that latest WIP and I was unable to do so. Can you consistently replicate this on your computer (as frustrating as it is to have to restart?) If so, can you please send along detailed steps so we can reproduce the bug?

Hi Dan
The problem occurred only once and I did not consider trying again. I have now tried to replicate but the problem did not occur. I have updated Rhino since it happened, which could perhaps explain why? More likely it was some other strange coincidence that caused the problem.

I’m glad things are working better now. This sort of thing sometimes happens…hard to say why. If you do find behaviors that seem like bugs that you can reproduce over and over, please do let us know.