Problem with geometry - real life terrain vs Rhino and Grasshopper


At the begining I must point our that I am new to Rhino :slight_smile:

I want to analyze in Grasshopper a surface which is a real hill slope. I created 3d model of a surface (via UAV survey) and imported it into Rhino and further - Grasshopper. This however was not possible.
Then I made a surface based on contours generated in QGIS as a dxf and thied to make at least simple sun path visualization. Without proper results. The same situation was observed while trying to perform radiation analysis - values of the kWh/m2 was totally wrong.

the shape no shape :slight_smile:
I think that values are too low… :slight_smile:

When I made a simple geometry (boxes and cilinders) everything worked fine therefore I think that original geometry is a problem.

Can somebody take a look at the attached file and tell what might be a reason for that and how to fix it? How to prepare files for future analyses to avoid this problem?

Thanks in advance

plot.3dm (277.2 KB)

Hi Peter - what is doing the anlysis? That’s not Rhino… In any case I would check the units in the file (DocumentProperties > Units page) and see if things look like they are the right scale.


Hi Pascal,

Thanks for immediate response!

My goal is to visualize few things:

  • how sun operates above the surface in different seasons,
  • how much of the solar energy is cnsumed by the surface and how this quantity differs in its particular spots due to slightly different slope pitch,
  • from which direction winds blow in a specific seasons through putting the wind rose the surface
  • others…

In fact I wanted to explore as much the GH potential as possible :slight_smile: Rhino however is the basis and since the same algos work properly on the other structures, I thought that problem lies on the side of structure I made in Rhino.

I already thought to the same conlcusion (scale) but - at least untill now - it does not work either. Possibly need to repeat my investigation… :slight_smile:

Seems that scale is ok. But the results are not :slight_smile: Investigation continues then…

Sounds like this is a Ladybug issue. Best to either wait to get @Mostapha to shed some light or go over to the Ladybug group on the Grasshopper site to ask questions.

thanks Wim!

It would be great if @Mostapha could take look at this.
I’ve checked geometry dimensions and orientation (if Y axis points north than everything is ok). Seems ok… So for now I am stuck. No more ideas how to solve this at the moment.

Just for the future reference this question is solved here:

1 Like