Problem with FlowalongSrf

Hi, I’m having issues trying to flow an array of square along a curved surface. The surface is formed by drawing a curve with points and then extruding it. When I try to flowalongsrf, the squares are not evenly spaced on my surface… Any idea why and how to fix this? Thanks.

Hi Nic - UnrollSrfUV the 3d surface and then use the result as the base surface for FlowAlongSrf. Any luck?

-Pascal

Yes, that seems to work! Great, thank you!

Hi @pascal, I’m having a similar problem where I’m using UnrollSrfUV to unroll my curved surface and then FlowAlongSrf to “move” my squares on the curved surface. If I toggle “rigid” to “yes” the spacing isn’t kept but with “rigid” no, it is… any idea how I could keep them rigid and spaced properly?

Here’s the file:

Rhino file

Actually, I found another one of your discussion on a similar topic and fixed my problem using the solutions you had proposed. Just in case others have the same issue, here’s what @pascal had proposed and worked for me:

  1. ShrinkTrimmedSrf (turns out my surface was already trimmed but I tried just in case)
  2. Then I “Rebuild” and more than doubled the U & V
  3. UnrollSrfUV (with Explode = no, not sure what it does)
  4. Finally FlowAlongSrf worked perfectly

Thanks @pascal for your continued help!

Hi Nic - this is a bug… it is fixed in the V6 WIP - it was fixed recently, but I believe it is in the most recent WIP release,

-Pascal

Thanks Pascal, however, I had the same result in the Windows version…

Hi Nic - It is fixed in the Windows V6 ‘WIP’ as far as I know. If that fix is not in the most recent WIP then it should appear soon- I’ll double check when I get back to the office, but I am pretty sure I tested a fix for this the other day, if we are talking about the same thing,

-Pascal

Ah, sorry I thought you meant the mac WIP as I also tested there and in the “normal” windows version. Thanks in any case for checking, your support is very appreciated.