Problem with flat surfaces rendering faceted

hello, i usually use rhino only for modeling but am trying to render something now and am running into a problem i can’t solve.

I have a number of cosed polysurface object i generated with grasshopper. i baked them to rhino and the objects seem completely normal. They are extruded in grasshopper from curves and capped so they have a flat surface on top.

When i try to render them all the objects appear faceted. I have tried everything i could think of, tried all kinds of different materials, converted them to mesh objects, rebuild meshnormals. When i use ‘Rendered’ in the viewport they appear flat as they should but if i use the raytraced viewport or try to render an image with cycles i get the facets.

not sure what i’m missing here :crazy_face:

Here’s the problem:

ok i think i figured it out: i copied the objects to a new file and now they render correctly. i think the issue might be that the grasshopper objects are still rendered together with the baked objects. Do grasshopper objects still render even if they are not displayed ?

If you have a custom display component in use and it is set to preview and render then yes, they will be rendered even without being baked.