Flat shading of meshes inconsistent

Hello everyone.

I have a question regarding normals. I have created 2 different simple geometries. One was created as a mesh from Grasshopper and then baked (the blue one), the other was created from polysurfaces in Rhino and then converted to a Mesh.

Whats strange is, that the red one is always shown with flat shading and when exported as .obj and imported in another renderer has flat normals and a sort of polygonal look. The blue one on the other hand has smoothed normals and in the Rhino viewport and other software is shown with a smoothed look, which I dont want - I want the same polygonal look.

I can enable flat shading in Rhino, but that doesnt effect how it is displayed in other renderers.

Whats the difference between the 2 that they are shown differently? How can I export it so that it has flat normals?



Flat shaded (what it should look like in rendered even without flat shade enabled):

flat_normals.3dm (92.2 KB)

Run the command _UnWeld with an angle of 0 before exporting, that should do it…

The weld angle is simply the threshold angle at which the display starts/stops smoothing. UnWeld with 0 removes all smoothing. You can use _Weld to put it back.

HTH, --Mitch

Thanks @Helvetosaur, that worked perfectly. Also found the same in GH and its working just the same!