Problem loading Kangaroo Solver.dll

Hi,

I tried to open Kangaroo2 scripting example, but found an error said:
Warning (CS1701): Assuming assembly reference ‘RhinoCommon, Version=5.1.30000.13, Culture=neutral, PublicKeyToken=552281e97c755530’ matches ‘RhinoCommon, Version=6.11.18348.17061, Culture=neutral, PublicKeyToken=552281e97c755530’, you may need to supply runtime policy

This happened after I set assembly location in Manage Assemblies.

Anyone know how to solve this?

This warning might be one you can dismiss and it will still work. Note also, if you are using Rhino 6, you need to reference the same Kangaroo dll that Grasshopper loads, which is something like
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\Components
(Not the one in the location you get to from the Grasshopper menu)

Hi Daniel,

Thank you for your reply. It works now…

Another question, I tried to make a custom goal from scratch (following your Kangaroo 2 scripting example). But, I get this message:
Error (CS0246): The type or namespace name ‘GoalObject’ could not be found (are you missing a using directive or an assembly reference?)

Do you know why this happened?

Oh I got it,

just need to copy:

using KangarooSolver;
using KangarooSolver.Goals;

Thanks!