Printed Layout gets all shadowy

I am hoping somebody can help me with this. When I print a layout page with rendered views, the printed image gets all shadowy.
This is how the layout UI looks:


The print window shows the preview pretty much the same:

But when I open the image as a pdf in Preview it gets all shadowy, and the actual print (direct from Rhino) is the same:

The layout details are rendered viewports, these are my display mode settings (the lighting part shown only):

What am I doing wrong? I am sure at one time it printed ok. I am running version 5.3.2. (5D197).

Max.

maybe it helps using SetObjectDisplayMode setting it to rendered instead of setting the whole view to rendered. i figured that it makes a difference in the shadow even though i dont know why because setting the viewport to rendered should shade the same.

anyhow if it shows a different image in the preview than in the actual pdf then this is sure not intended so probably a bug.

Hi Maxz - can you please post the file or send it to tech@mcneel.com? There have been some comments on this item, not visible to you, to the effect that so far we cannot reproduce the problem - having the same model will at least get us partway on the same page.

thanks,

-Pascal

@pascal I have sent the file, after I made sure the “problem” still exists on my computer. I also included the .pdf generated from Rhino via the printing interface.

Max.

Hi Maxz - thanks, I see the problem here as well. Correct in Windows Rhino…
I’ll make a bug track item.
https://mcneel.myjetbrains.com/youtrack/issue/MR-3147

-Pascal

Looks like the bug track item is not for public viewing…

Hi Maxz - the bug should be but not the attached file since you sent that privately - let me make sure - try now…

-Pascal

Looks ok now, thanks.

Max.

Hi @maxz,

The next Rhino 5 for Mac WIP and the upcoming 5.4 official update will have this fix. Thank you.

1 Like

MR-3147 should be better in the latest RhinoWIP (5E292w). Please give it a whirl.

Hi @dan, I downloaded the latest WIP and tested it. Shadows are gone, everything lit as it should be. Thanks for resolving it guys.

Max.

1 Like