Print to PDF Option Results in Null File

I’ve done a couple of search and not found that this topic has been posted yet, but the print to PDF option results in a 0 byte file in Rhino 6 Beta, and at the same time none of my 3rd party print to PDF options show as available from the list of printers. They do show up and work normally in RH5, however.

Up until the latest update I was able to print to PDF with RH6 Beta without issue.

Anyone else have problems with this?

There have been many reports over many years of the Adobe PDF printer causing crashes Rhino to crash. McNeel wrote a new PDF exporter for Rhino 6 and in one of the more recent beta’s, all other PDF printers are set to hidden. You can turn on visibility of 3rd party PDF printers here:

Rhino Options > Advanced > Rhino.Options.Appearance.ShowExternalPdfPrinters

by default this is set to False; set it to True to let you use other printers.

That being said, you would most likely help development if you were able to share a file that does not print with the native Rhino PDF printer!

I have not had any other reports of this problem. If possible, please send me the 3dm file that is having problems writing to PDF. I would like to try and fix this as soon as possible.

Adobe invented *.pdf. Shouldn’t they be able to drive it? :tophat:

Sorry, I don’t understand that comment. Is there something you want changed?

Thanks for your reply Steve. Attached is the 3dm in question, as well as an export that worked from the third party PDF app CutePDF.
17001 - PDF Export Issue-cutepdf.pdf (39.4 KB)
17001 - PDF Export Issue.3dm (4.8 MB)

Thanks wim, I didn’t realize that there was an option to reveal the external PDF printers. After checking this box, I was able to get workable prints through CutePDF and FoxitPDF. Above there is a reply to Steve with the files in question.

I see something wrong, but am not entirely sure I am seeing what you are. Can you explain what you mean by a “Null File”?

Sure! The output file is 0 bytes. I tried to upload that file, but the server doesn’t allow (understandably) 0 byte files.

Ok; that is definitely NOT the bug that I’m seeing. This happened when trying to print the A0 sheet that you attached a cute PDF version of or were you trying to print a different sheet?

Thanks for your patience with my questions.

This is when I tried to print any layout view from the original file before I scrubbed it of client data. But I also attempted to print the layout sheet (A0.00) at ARCH D from the attached file to no avail.

However, I have had success making another file and saving that layout to pdf. So I’m guessing it must be file-specific.