Print set window is like a rectangle possessed!


#1

Hi
V4 set window a translucent rectangle appears and you move it.

I seem very prone in V5 to having it jump I rexoze it my a corner and it jumps down screen, moving it is the middle point, took a while to spot that. It just wont let me resize it by a corner or so it seems.

I set it up in Front view. Print.

then go to Back view and expect to see it there but its far far away. Move it and have to resize it.
then front view its gone from there…and so on.

The pdf that results set to high qlty sees a black line part way along go green…

Steve


(Steve Baer) #2

It shouldn’t behave a whole lot different than V4. Do you have some snaps on in V5 that are not on in V4?


#3

Hi,
It has been given a total revamp, very unlike V4, it has control points at corners and in middle, resizing it via corner sees it jump from location and you have to resite it. Then you find its stil not right and resize it and it jumps again.

I also do wish that having sites in in Front, when going Back view its the same place on ones model.

Steve


#4

@Steve1

I did have the same issues with the V5 print set window and did report them (in the olden days of the newsgroup)
The problem never seemed to be addressed for a very long time and I kind of resigned and got used to dealing with it, until a couple of updates ago it finally got resolved.
Unfortunately I really don’t know what fixed this problem for me and can’t track down the exact point in time/upgrade that made the problem finally disappear.
But as this behavior continues on your side I suspect it might be related to a specific hardware or software (plug-ins, mouse drivers etc) configuration?

and @stevebaer
While snapping can interfere with the placement of the set print window, the problem described by Steve1 is another:
Any movement of one of the corner points would make the set print window “jump” resulting in a complete offset (usually – in my case – to the right and down placing the set print window partially outside the screen)
As I said, for me the problem vanished a couple of upgrades ago.

Norbert

P.S.: I just experienced the “jumping” behavior, no black lines etc when printing pdf’s

Edit: by “just” I meant “only”.


#5

I think the jumping you refer to is due to osnaps. Your cursor will be attracted to geometry in the model as you move the print window around.
I just disable osnaps whenever I use set window.


#6

Sorry but that is not the case.
As I said, I had this problem for a long time and naturally I tried to see if disabling osnaps solves it: nope!

I still don’t know if this was resolved (in my case) by something that McNeel did or if something in my setup changed and made it disappear.

Norbert


#7

FWIW same here. The “leaping around” print window was an issue for me for some time that now appears to have gone away. No idea what caused it, or what fixed it, but all seems good now.


#8

weird. never had this on my end (except because of osnaps)


(Steve Baer) #9

Well… I did make fixes to this code over the lifetime of Rhino 5. It didn’t just ‘magically’ go away :smile:


#10

Well it clearly worked, so that’s “magic” to me :wink: Thanks for fixing it Steve.


#11

Good to know and I am thankful for that.

Some people still seem to have issues though…

Cheers, Norbert


(Steve Baer) #12

Sure, that’s why this post exists :smirk: Was just pointing out that this was an area that there were several bug reports about on the old newsgroup during V5 development and changes were made to attempt to fix those issues. Still not perfect though.