Possibile symbol/mesh preview bug

grasshopper
bug
preview

#1

Hi everyone! Sorry if it has already been posted, but I can’t find any reference to this bug. The preview component has some odd behaviour, as shown by the following images.

1) Curve preview and symbol preview (Shaded viewport in Rhinoceros)

Enabled, preview on (works fine):

Enabled, preview off (also works fine):

Disabled, preview on (it’s a bug as mentioned by @DavidRutten):

Disabled, preview off (works fine):

2) Mesh preview (doesn’t really depend on the mesh being previewed)

Enabled, preview on, shaded viewport (works fine):

Enabled, preview off, shaded viewport (works fine):

Enabled, preview off, rendered viewport (shows the mesh even if each preview is off, both the mesh original component and the Custom Preview component: is it supposed to be like this?)

Disabled, preview off/on, rendered viewport (works fine):

Sample file, but it actually behaves the same with any mesh/symbol:
Sample_Preview bug.gh (5.6 KB)

Any idea on why this could happen?
Thanks!


#2

No file, and no description of what was expected an what is considered being wrong in each case.

// Rolf


(David Rutten) #3

Yup, that’s a bug. I’ve logged it under RH-46609

As for the preview mesh in Rendered, are you referring to the fact that the groundplane is at elevation=0 rather than at the bottom of the sphere? If yes, that was logged under RH-29918 and claims to have been fixed. Although looking into that issue now is seems it was closed without being merged into the main code. I’ll re-open it again.


#4

Sorry @RIL , I’ve edited the original post!

Great, thanks!

@DavidRutten Actually I was referring to the fact that the object (any mesh/brep, I used a GH primitive as an example) shows in the rendered Rhino viewport even if all previews are turned off, while switching to shaded without modifying the GH file hides them. Is it supposed to be like this?


(David Rutten) #5

Yes. I think so. The Custom Preview component will draw previews in ‘non-render’ viewports such as Wireframe, Shaded, XRay, and it will send meshes+materials to the render pipeline in ‘render’ viewports such as Rendered, Arctic, Raytraced and regular renderings.

You can disable the preview and rendering separately from the component menu.


#6

Got it, thanks!