Plugin license issue


(Matthieu Arnold) #1

Hi, I created a plugin with your license system.
It works fine on my computer, but I tried on my colleague’s computer and I get a strange message:

No license found on your system. The plugin won’t work without a valid license. “Try” / “Close”

I don’t get why a trial is offered, and there is nowhere to enter a product key!? Usually we have a window where we can choose to select a zoo server or add a standalone license!

I don’t get the difference between my computer and his’. (Windows 10, Rhino 64bits)


(Dale Fugier) #2

Hi Matthieu,

Are both systems running the same service release of Rhino 5?

– Dale


(Matthieu Arnold) #3

Hi Dale,
I just Checked and he has the V5 SR13 while I have the V5 SR12.
I will try to update, recompile and re-test. A strange thing is that my SR12 says it is up-to-date, I’ll try to get it from your website.
I’ll keep you informed.
Best Regards


(Matthieu Arnold) #4

Hi Dale,
We tried with the same service release, and the issue remains… Any idea?
Regards


(Dale Fugier) #5

HI Matthieu,

Rhino.PlugIns.PlugIn has 2 GetLicense functions.

Which one is your plug-in calling when it loads?

You should be calling the one decorated like this:

public bool GetLicense(LicenseCapabilities licenseCapabilities, string textMask, ValidateProductKeyDelegate validateDelegate);

– Dale


(Matthieu Arnold) #6

Hi Dale,
This is the one I’ve been using:

Dim validator As New Rhino.PlugIns.ValidateProductKeyDelegate(AddressOf ValidateProductKey)
Dim rc As Boolean = GetLicense(Rhino.PlugIns.LicenseBuildType.Release, ">LLLAAA\-AAAAAA\-AAAAAA\-AAAAAA", validator)

(Dale Fugier) #7

Have you tried the other, new method?


(Matthieu Arnold) #8

Hi,
I did a few tests, and got it to work:

  • GetLicense() without the textmask always seems to work.
  • GetLicense() with the textmask works only up to service release 12. My issue apparently came from SR13, you might want to check it on your side.

Anyway I’ll be fine without the textmask, so thanks for your help
Regards

Matthieu