Plugging vector list into vector display doesn't work

Hi! I’m very new to grasshopper, I apologise if this is a noobie mistake (or if my wording isn’t clear enough, I don’t know what I’m doing). I don’t understand why it gives me this error message when I try to filter vectors out of my simulation - the message it gives me when I open the message is “Data conversion failed from number to vector”. Is there a node I can use to convert the “L” output into a “V” output?
Thank you in advance!

Instead of connecting the DeVec ‘Y’ output to Cull ‘L’, use the VecStar ‘V’ output?

Posting the image of code alone, without the actual GH file, makes it impossible for anyone to really be sure about giving you any advice. (or better yet, giving you a tested and working GH file)

3. Attach minimal versions of all the relevant files

Thank you for your reply! Yeah, that’s what I’ll do if I can’t manage to cull part of the vectors, but the vecstar output gives me the whole “sphere” of vectors and I only want half of it, which is why I’m trying to cull them. Thank you also for the suggestion of attaching the file! Here it is (45.3 KB)


And you didn’t internalize your geometry (brep and points). so this GH file is useless to me.

You’re right, thank you. The plugins are indeed pachyderm and pufferfish, I baked the references, I hope this is how one internalizes geometry. I apologise again, I’m very, very new to this software. (42.2 KB)

No, it is not the correct way. Baking has nothing to do with it. I don’t have your .3dm file so the brep and points are still empty. You can either post your .3dm file or right-click on the Brep and Pt params (one at a time) and choose “Internalize data”.

I won’t install your plugins (and seriously doubt that you really need them?), but maybe someone else will help you.

Thank you again - I internalized the files but it exceeds 20mb, I must attach it with a wetransfer. But really, I don’t think the plugins and geometry have much to do with the error, it’s “just” a matter of inputs and outputs and I can’t figure it out, I’ve seen people plugging “L” into “V” with no issue, I don’t understand. Regardless, thank you so much for your time!

(also I really think I need the pachyderm plugin, it’s specifically for acoustics simulations, which is what I must do. Is there any other way to get to a similar result without extensive coding?)

Did you try the suggestion I made in my first response? Good luck.

I did! And it works, but it doesn’t cull the vectors I need to cull, so it sadly won’t simulate the rays I need. Have a great afternoon, thank you again!

Hi Giulia,

Is this what you are after?

The problem is that you are only feeding the y value into the Vector Display component.
A vector is composed of 3 numbers represented as X,Y,Z.

To create a Y vector from numbers it would be 0,1,0

Therefore you can filter based on the y, but dispatch the X and Z as well and return a full vector to feed to the vector display.

Please see the attached modification of your script where I show the result and outline the logic involved.

Cheers! (13.5 KB)


And here’s a version where you can select what direction you want and invert that direction as well: (8.3 KB)

1 Like

I said the same thing three hours ago.

But the solution I suggested was far simpler than filtering all three (X, Y and Z) params and reconstructing the vectors. Apparently it worked, except the wrong vectors were culled, which is a different issue:

Instead of connecting the DeVec ‘Y’ output to Cull ‘L’, use the VecStar ‘V’ output?

Yes you did! I was just trying to visually show them why a number to vector doesn’t work in the way they were expecting it to.

The simplified version is as you suggested and I think the wrong vectors being culled was his (or mine?) pattern being set to inverted on the Cull Pattern component.

I attached the simplified script as a follow up that I think will get them where they need to be.

1 Like

THANK YOU SO MUCH!!! It worked, your explaination was very clear, thank you so much.

1 Like

You’re welcome! Happy to have helped!