PlanarSrf partially working


#1

Hi,

I was hoping that someone could help me with a file I am working on. It’s based on a video tutorial and I am stuck with the PlanarSrf command. I have a 100 closed curves arrayed around a circle but only 3 will work with the Planarsrf command.

Video : https://www.youtube.com/watch?v=mR9CnlnE-pA&t=722s I am at 12 minutes, that’s where I am stuck right now. In the video, everything works fine.

I hope someone have an idea on how to solve this.

Thank you very much in advance !

Untitled.3dm (3.9 MB)


(Pascal Golay) #2

Hi Deniel - it looks like the curves are not quite planar - how are you making these?

-Pascal


#3

Well, I created the geometry using the loft command and then used the extractwireframe command. The odd thing is that some curves are working with the PlanarSrf command the others don’t even though they were created in the same way. Also, it’s the exact same process as in the video where the person had no problem with the command.


(Pascal Golay) #4

Hi Deniel - that may work, sometimes in special cases but it is not a reliable way to get planar curves - use the Section command for that, I would say.

-Pascal


#5

Thank you Pascal for your help !

The problem is that I don’t think I could get the same geometry with the section tool (At least as far as I know). If you turn on the red layer you can see that it is really complex. Basically a fairly regular and close frame extracted from an object.

Is there a way to make these curves planar and make them work with the PlanarSrf command?


(Pascal Golay) #6

Hi Daniel - try:

  1. The red curves layer on
  2. Place a point in the middle from Top
  3. Select the curves
    4.Section. Set GroupOutputBySectionPLame=Yes.
  4. Set as many radial sections as you want, snapping to the middle point each time.
  5. Select each group of points and CurveThroughPt > Closed=Yes,> CurveType=InterpolatedKnots=Uniform, Id’say

These curves will be planar and should do what you need.

-Pascal