PictureFrame objects will not print in vector mode

I’ve found that PictureFrame objects completely disappear in the print dialogue box when ‘Vector’ is chosen rather than ‘Raster’. These objects will also not appear on printed pages or saved PDFs. If ‘Raster’ is selected then the jpegs will show up, but I do need to create vector files.

Things I’ve tried:

  • The PictureFrames are definitely on layers with the print visibility turned on.
  • I’ve tried creating the PictureFrames in model space and placing them on to my layout page through a detail. They are still not visible.
  • ‘Embed bitmap’ turned on in PictureFrame dialogue box.
  • Opening the file on a coworkers computer. The problem is replicated.

My workaround has been to ‘print’ the file as a PDF, then open it up in Illustrator and replace the missing images, I would prefer not to have to do this every time.

What am I doing wrong? or is this a bug? Any other suggested workarounds or alternative methods for image placement?

Running Rhino 5.4 (5E407) on a Late 2015 iMac, 3.2 Intel i5, 16GB RAM, AMD Radeon R9 M390

I’m sorry to report that this is a bug in Rhino 5 for Mac. It’s probably cold comfort to say that we have fixed this bug for Rhino 6 for Mac (RhinoWIP coming soonish).

Sorry you have to use the awkward workaround.

Dan, thanks for getting back to me so quickly. Glad to hear that a fix is in the works.

In the mean time another coworker has found an ‘In Rhino’ workaround; place the PictureFrame image in model space, in Layout create a viewport for the image and set the display mode of that viewport to ‘shaded’. The image will now appear in the print dialogue vector mode and will output just fine.

I had tried this method before but had not changed the viewport display mode. It’s still a a workaround, but is much faster than the method I was using before.


It still doesnt work in rhino 7 !

Can you help me reproduce the issue? I’m not able to reproduce this (pictures show up for me in Vector mode prints). Let’s compare our steps. Here is what I’m doing…

  1. I have TestImage.png on my Desktop.
  2. In Rhino for Mac 7 (7.23.22245.17002), I’m starting a new modeling window.
  3. I run the Picture command. In the Top viewport, I draw a box. The image appears in the viewport.
  4. On my keyboard, I press Command+P to open the Print dialog.
  5. In the Print dialog, I pressed Show Details to show the detailed controls.
  6. In Output and Scaling, under Printer output:, I selected Vector output.
  7. At the bottom of the dialog, under the PDF drop-down, I selected Save As PDF.
  8. I saved TestVectorWithImage.pdf to my desktop.
  9. In Preview.app, I can see that TestVectorWithImage.pdf contains the TestImage.png as expected.

What are we doing differently?