Perspective without heights ? :s

Hello ,
it sucks , I’ve never had this problem before: i can’t create outside grid level in perspective view like before.
" planar "is disabled.
I restored defaults the 4 viewports but it didn’t work. the example shows. its missing coordinates in Z axis ,so …what is the solution ??
ps:i don’t want to come and back on front/right view or elevator mode for lack of better :wink:

Hello - all curve drawing input goes to the construction plane unless you override it somehow - say with OSnaps or something to existing geometry. This has never been otherwise in Rhino. Using elevator mode, then turning on Planar would make subsequent input go to the same Z as the elevatored point unless overrridden by a snap etc.


… other than that, perhaps you had OneView active before?
But then you would have had the grid change when the perspective view gets close to one of the other CPlanes and you’d still be drawing on the grid.

1 Like

hi, thanks you for your answer
no, i active and disabled oneview and try options didn’t work
My actual perspective is constrain only by XY axis also for new example I can’t draw a vertical line from the perspective view. My line is folded down on the grid rather going up

Hi Tommy -

That’s the expected behavior.

1 Like

Just to add what others have said, remember that drawing in perspective , has the same construction plane as top view(drawing).—-Mark

1 Like

dear @Tommy1 can you describe / sketch (the second view) the curve you expected to draw ?
so maybe we can help with a workflow that is as you expected - regarding the result.

my guess:
draw the first point(s)
then change the cplane in perspective view
draw additiona Point(s) (in perspective, on c-plane front)
reset cplane or change…
draw the final part of the curve.


kind regards, tom