PDF hidden lines print solid?

Good day. I am encountering an issue trying to print hidden lines (dots or dashes) to a pdf document.
I have reviewed all my settings and tried various pdf printer software, however the problem persists.
If someone on the forum has some insight to this it will be greatly appreciated.

To provide some context, the issue is being experienced using both Windows and Mac versions although to lesser degrees. The problem exists using both vector and raster settings, and several additional settings have been adjusted with no positive outcome.

The one setting that does provide some variation in the correct direction is the resolution, however both the result and quality as a result are not suitable solutions.

The below screenshots provide some additional reference. Image 1 is the Rhino UI where the hidden lines are clearly visible. Image 2 shows the pdf print (600 dpi) where the lines while lighter in colour are solid and image 3 shows a lower resolution pdf (100 dpi) with the hidden lines closer to the desired output similar to the Rhino UI.
Thank you, in advance for all assistance, Rob.

Thank you, in advance, Rob.

Hi Rob - I guess the hidden lines are defined in pixels and not in any real dimension - my guess is if you zoom in enough on the light lines at 600 dpi in the pdf they are probably ‘dashed’.

I am not sure what can be done here - I think the hidden lines in Technical are a ‘cheap trick’ and not very rigorously defined, but I’ll get it onto the pile.


Hi Pascal, thank you for the feedback and understood. You are correct that when I zoom in on the “solid” lines they in fact broken, however not in any regular way as one would expect from either a dashed or dotted line. Below is a screenshot of the “hidden” line from the 600 dpi pdf file.

Thanks for the assistance, all the best, Rob.

Considering Pascals feedback, if anybody has a suggestion or solution as to how this issue can be worked around, I look forward to your input.
Thank you in advance, Rob.

Hi -

For the time being, you might want to look into using the Make2D command. That will give you full control over the appearance of the curves.

Hi Wim, thank you for the suggestion. I am familiar with the Make2D command, and use it regularly, however in this case, I must follow a different workflow and Make2D wont work.
I was wondering if there was a “magical” Grasshopper solution :slight_smile: