Pdf export

When I try to export a drawing as pdf, the file is not scaled correctly. Anyone else having this problem or even knows a solution? When I export as .AI, the scaling works properly.

Hello - in the pdf print dialog, are you setting the scale 1:1?


No, not 1:1. I always draw in the actual dimensions and only scale by exporting
I changed it to 1:200 for my drawings and they scale differently to 1:200 in .ai

Hi Isabelle - can you post a simple 3dm file that shows what you are describing?

yes of course. I radically minimized the file for the upload and included two images that show that the pdf export menu does not properly work for me.
In the drop down menu I can choose a scale but it doesnt change in paper and model. So when I want to export in 1:1000, it doesn’t react
SEE_min.3dm (100.1 KB)

Hi Isabelle -
Thank you for that file!

Since you are trying to export to PDF, I don’t think we need to go further into the AI export but I did try that here in an attempt to reproduce your results. There is no scale drop-down for AI export as there is for PDF export and so I assume that you used “Preserve model scale” and “1 meters = 20000 cm”. When I then imported that AI with “Preserve units” and “1 mm in AI 1 Rhino unit”, the result didn’t make much sense to me.

At any rate, that’s probably not important for now.

I agree with you on that one. There appear to be several things that are not working correctly here. I’ll have to further look into these issues and check if they are already known bugs that are on the list. If not, I will add new items.

That said, the resulting PDF file, here, did end up being correctly scaled to 1:200. But I suppose there is a multitude of different workflows that are possible here and I didn’t test every combination.
These were my steps:

  • Opened your file - that opened with a maximized “Perspektive” viewport and I left it that way
  • I added one dimension to be able to check this afterward
  • Selected all curves
  • Ran Export and picked the PDF format
  • In the View and Output Scale section, I picked the Drauf viewport
  • In the pull-down under Scale, I selected 1:200 and I changed “On Paper” from Inches to Centimeters
  • At this point, the preview window still didn’t show anything, so I changed View and Output Scale from Viewport to Extents. That didn’t help the preview window but I clicked OK to export anyway.

Then, in a different Rhino session with a default millimeters template, I imported the PDF with the Preserve units - 1 mm in PDF 1 Rhino unit setting. I then created a dimension style to show both the current Rhino units and an alternate unit with the following settings:

I then created a new dimension that measures the dimension that I added in your file and that shows that the drawing is correctly scaled:

At any rate - given the issues with the Export dialog, and as long as we are on Windows, I would recommend using the Print command to create PDF files. I would also create a layout, scale the detail as required, and then print 1:1.

Hi Wim,
thank you for your elaborated answer.

Yes, the AI export is not a problem. I only said that for checked scaling.

My workflow is pretty much the same as yours. I encountered the problem several times already with different scale settings. I cannot reproduce the issue every time, it seems to be completely random when it happens or not.

Yes, we are talking about Windows. I thank you very much for the trick with the Print command.