Panel properties does not display properly rigthand side buttons


  • select a Panel component
  • right click “Edit Notes…”


Software information

Software versions
Rhinoceros version: 5.4 WIP (5E78w)
Rhinoceros path: /Applications/
IronPython version: not installed
WIP expiration: 16 June 2017
Language: en-FR (MacOS default)
macOS version: Version 10.12.4 (Build 16E195)


Third party kernel extensions
org.virtualbox.kext.VBoxDrv (5.0.16) 35F02C29-8027-3636-ACD2-6F171A50C1D8
org.virtualbox.kext.VBoxUSB (5.0.16) BD2570CD-7993-3635-BE1E-FAB977FFBD5C
org.virtualbox.kext.VBoxNetFlt (5.0.16) 2C1775A7-B7A3-32A2-9E8B-951C1B499870
org.virtualbox.kext.VBoxNetAdp (5.0.16) B108642D-2C95-3CB4-8D0B-01F867E60FBF

Hardware information

Computer hardware
Hardware model: MacBookPro9,1
Processor: Intel Core i7-3615QM CPU @ 2.30GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 512 MB
Memory: 512 MB
Screen size: 1440 x 900
Displays: Color LCD (111dpi 1x)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Receiver

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.16.34 355.10.05.35f05
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Interesting. Thanks for reporting this and providing your system information.

Unfortunately, I’m not seeing this behavior in RhinoWIP 5E78w. Here is what I see:

Does the white rectangle that is occluding the menu items on the right side behave like a scroll bar for you? What happens when you drag the lower right-hand corner of the Panel Properties window to resize the window?

Anyone else here seeing this odd behavior?

Looks like a scroll bar getting in the way. Is that the problem?

Indeed, this is a white rectangle that looks like a scroll bar. However, this is not a scroll bar.
For your information, when the mouse cursor is on the white rectangle at the place where the button “Draw indices” should be visible, the information message “Draw indices … Prefix the item…” appears.

That appears to be a bug. It seems to happen if you’re not using a trackpad, or have System Preferences > General > Show scroll bars set to ‘Always’. In this case, the main panel thinks it needs to scroll when it does not.

I’ve logged a YT item for it here.

1 Like

Hi, indeed, I am not using a trackpad. Below is the general configuration of my account.

This bug should finally be fixed in the latest RhinoWIP.

Indeed. The bug is fixed. Thank you.

1 Like