Package Manager has left town

This all started in an attempt to take the Denoiser out for a spin. I see AMD listed first, I beeline for it disregarding anything else since there’s a Radeon Pro 5600M on board. It took a few seconds longer than expected for something to happen when typing the PackageManager command, but the new-to-me dialog came up and I selected AMD. As Scott’s announcement post instructed, I restarted RhinoWIP only to get a “Rhino has unexpectedly quit” warning.

At the next opportunity, I loaded my SubD model and hit the Render button. The render screen showed no sign of the Denoiser option to check-mark. Killed the render operation and typed the PackageManager command. 15 seconds of waiting and nothing shows up. Found “Package Manager” listed under the Tools menu. Nothing comes of that either. Reboot? Yeah, that’s always the answer. I may have gotten another “Rhino has unexpectedly quit” either here or at the start of the next launch. Next launch, I definitely got the type of error that reports back to McNeel.

By the time I get back into Rhino, I load a fresh template, make a SubD sphere, start a Render and verify there’s still no Denoiser. Package Manager still not invokable through command line or menu listing.

Preference > Plug-ins shows:

Deactivating AMD Denoiser from the Plug-Ins list still doesn’t bring Package Manager back. The polite suggestion to use the Intel Denoiser for Macs should’ve probably been injected into the AMD listing.

Is nuking RhinoWIP the only way to restore PackageManager?

Attempted to paste diagnostic stuff from one of the error screens, but at 16,000 characters, it exceeds some kind of forum limit. They’ve been initially sent via the reporting process.

I’ve been trying to figure out the cause of this bug for the last couple days. I can repeat the issue, but still haven’t identified the root cause.

The WIP update available tonight (8-11-2020) was installed the moment I saw its availability and after loading my SubD project file, I invoked Package Manager from the tools menu to have this pop up:

Closing down my 3DM file, then exiting Rhino didn’t trigger any “unexpectedly quit” warnings. No warnings on relaunch of the new WIP either.

Once back in Rhino, typing the PackageManager command brings up the pictured “Could not load” warning consistently.

This is seen on Windows as well.

Tonight’s new WIP build 2020-08-18 got me grabbing it faster than prime loot in a Battle Royale match.

Tools > Package Manager is accessible again. Hurrah!

Being a good beta tester, I invoked a Render (ill-advised AMD Denoiser still loaded, presumably) and to no one’s surprise, the render progress window did not show any checkbox to activate the Denoiser.

Returned to Package Manager to Uninstall the AMD Denoiser.

Next, scrolled down to find the Intel Denoiser and got this on hitting the install button…

This error message popped up because version 0.3.0 of the IntelDenoiser had been published for windows, but at that point it hadn’t been published for mac.

I’m going to tune up the UI to make this less confusing. Most likely I’ll hide package versions if they aren’t compatible with the current platform and/or version of rhino that you’re browsing from.

To give some background, distributions are a subset of versions and were added to support the packaging of platform-specific and rhino-version-specific plug-ins. More information is on the devdocs site if you’re curious.

@CarterTG There should be a new version of the Intel denoiser available right now. I’d be interested in knowing whether it works for you.


Thank you @DavidEranen & @will!

Intel Denoiser downloaded without issues, and after a relaunch, shows up in the render progress window.

I ran a 2-minute test on each (8-core i9 5.0ghz)

MUCH prefer to stare at a denoised version than grain. The only grain I’ll keep is that tiny one hoping I’ll be able to use this on the MacBook’s Radeon Pro 5600M some day :grin: