OSX V5 updates wiping out settings


#1

I do a huge amount of my work in Rhino that gets exported to AutoCad and have some specific settings in the export dialog to ensure I know what is being exported. The last couple of Rhino 5 for OSX updates seem to have wiped those settings out and I’ve had to set them back up the first time I’ve gone to export to DXF/DWG format. This never used to be the case. Wondering if something has changed ? Currently using Mac mini running OSX 10.14 and Rhino for Mac 5.5.2 (5F85)


(Dan Belcher) #2

I apologize for the delayed reply. Am I understanding correctly that you have to set these settings in the DWG Export dialog every single time you export? Whereas they used to be sticky between both exports and sessions of Rhino?


#3

Hi Dan. Not quite. It’s OK once the settings have been entered & saved, I don’t have to enter them every time I export. Once they are set up they stick. It’s when an update for Rhino OSX is applied, whereas it used to be the settings would translate across into the new update(s). I’ve only noticed it in the last couple of updates over the last 4 or 5 months. Its not a day to day thing, its just a pain in the ass type thing each time the program is updated


(Dan Belcher) #4

Ok, thank you for the clarification. That helps. So it’s between updates of Rhino for Mac - even minor ones - that are causing these to go away. We did do some major work in Rhino 5.5 (and after) to support preference compatibility with the RhinoWIP, so this might have been the culprit. We will likely have another minor update to Rhino 5 for Mac, so I would encourage you to run ExportPreferences first to get a backup. That way, when it happens, we can compare before/after. I’m sorry, this sounds annoying.