Osnap modifier hold-down


#1

Is there any way to add a modifier key such that when it’s held down, overrides all Osnap settings except a preset one (that’s been assigned to that key)? For example, Nearest. I’m getting a bit p****d off with the strength of Centre Osnap which steamrollers everything else. It’s even stronger on surfaces than closed rectangle lines etc, to the point where it’s impossible to snap to anything OTHER than Centre.


#2

I have the same feeling about CEN… Another one that allways gets in the way is PERP (try to draw i line from the center of a circle and try to snap to QUAD). These two are literally driving me crazy every day (I’m NOT exaggerating). I’ve been posting about these issues a couple of times (since V4), but obviously people think they are working as they should, as nobody was responding… :smile: I would be happy if we could find a (better) solution regarding overlapping osnaps…
Thanks!

Philip


(Wim Dekeyser) #3

I just don’t have CEN (nor Perp) enabled as persistent snaps. Easy enough to just type cen whenever I need it…


(Pascal Golay) #4

Hi Matt- any typed or specifically set osnap will override any persistent ones for one pick- e.g. If you type Int and Enter while Rhino is looking for a point, Int is the only snap that will be active, regardless of what is checked in the Osnap box. So, you could make an alias or put it on a shortcut key that you can use any time.

-Pascal


#5

That’s all understood. Currently I hit Nearest as a one shot to ‘kill’ Centre, but I’m doing it several hundred times a day atm and the mouse miles clock up, especially on 20"+30"+20" screen set up. Disabling persistent Centre and Perp just moves the problem elsewhere and doesn’t reduce the amount of input (I use both heavily on the same job) required. Again, typing inputs on the command line just adds work (i.e. focus taken away from screen 3 keys + return to hit instead of one button), not reduces it.

I think I’ll just assign one-hit Nearest to a function key and make do with that.


(Pascal Golay) #6

Right, that is what I was getting at.

-Pascal


#7

That doesn’t necessarily work if you have smart tracking enabled - and active tracking points in the model… and it doesn’t always help to hit Ctrl twice (to get rid of the smart tracking points). Int seem to be the one always getting in the way…

Philip