openNURBS on visual studio 2017

opennurbs

(2eleveneleven2) #1

Hi everyone,

I faced a problem when I tried to compile openNURBS.

I download from your homepage, and merely open the project “opennurbs_public”, then, I clicked build project. I obtained an error.

“Error C2065 ‘AF_SCRIPT_CYRL’: undeclared identifier.”

I searched something on google. People do have same problem, which is caused by the wrong charset used by VS 2017 to interpret the source file. However, I still can’t solve this problem.

My computer is on a windows 10 with visual studio 2017 community version. OpenNURBS is the latest version.

Thanks in advanced.


(Dale Fugier) #2

Hi @2eleveneleven2,

I just download, unzipped and successfully build the latest openNURBS (opennurbs_6.1.18014.22401.zip), both Debug and Release with Microsoft Visual Studio Community 2017 (Version 15.7.2).

It sounds like you may not have enough C++ installed. You may want to re-run the Visual Studio installer and make sure the required C++ components are installed. On Windows 10, click Cortana and type “Visual Studio Installer”.

– Dale


(2eleveneleven2) #3

Dear Dale,

Thanks for you reply.

I did what you did in your reply, and I just build the solution without changing any default setting.

Could you please check this address ? I think it may be the same reason, but I still can’t figure it out. By the way, do I have to install Rhino 6 to use openNURBS ? I only have version 5, and I don’t think I need rhino 6 for openNURBS.

Attached figure is what I have already installed. I followed your instruction for openNURBS.

Regards.


(2eleveneleven2) #4

Dear Everyone,

I solved this problem. I just set my system display English completely instead of some Chinese, then the problem is solved. Everything works well.


(Caojunqi) #5

Hi,I just faced a problem like you,I can’t compile openNubrs well,
"E0040 excepeted an identifieer”
“initializer is not a constant”
“Error C2065 ‘AF_SCRIPT_CYRL’: undeclared identifier.”
"cannot open file ‘C:/opennubrs/bin/x64/Debug/freetype263.lib’ "