Errors when building opennurbs_public.sln in VS 2017


(Anja Elser) #1

Hi,

I want to link to ON in my own programm. But I’m getting errors when I try to build the latest opennurbs_public.sln in VS 2017 Community. As far as I can understand they are all concened with ON_BinaryArchive being not defined (E0020) in opennurbs_archive.h and ON_TextLog beeing not defined in opennurbs_unicode. I can still build the projects, but then the errors are the same when I link to the libraries opennurbs_public, zlib and freetype263. Since i’m not used to all this, it is possible that I am forgetting something basic…

What i’m essentially doing is opening the solution and building. I tried building all and then building only zlib/ freetype263/opennurbs_public (in this order, since I saw that opennurbs_public depends on the other two).

Do I have to do any special settings in VS before building?

Thanks!


(Dale Fugier) #2

Hi @anja.elser,

I just downloaded the latest opennurbs, opened the opennurbs_public.sln solution in Visual Studio Community 2017 (version 15.5.6), and built the solution in all configurations and platforms without warning or error. So in order to be helpful, we are going to need more information. Do you have all of the necessary Visual Studio C++ components installed?

http://developer.rhino3d.com/guides/cpp/installing-tools-windows/

Thanks,

– Dale


(Anja Elser) #3

Hi Dale,

thanks for your answer!

indeed I didn’t install some if the required components. Unfortunately installing them didn’t solve the problem. I am pritty sure that there is still a problem with my settings. I loaded the property sheet manually, just for beeing sure this is not the problem. I tried several SDK Verisons (following your link this is 10.0.14393.0) but none of them worked. I tried setting the toolset to VS2015 (since in http://developer.rhino3d.com/guides/opennurbs/getting-started/ it sais that ON has been tested with VS 2015).

I also tried downloading again to be sure I didn’t make any changes to the project. I didn’t move the folder to be sure that it is no path problem. I have no empty characters in the path.

My VS Version is 15.5.6.

The errors appear when I load the solution and then open any of the opennurbs_xyz files.

I hope some of the above information is helpful…

Thanks again!

Anja


(Dale Fugier) #4

Hi @anja.elser,

What property sheet? There should be nothing you need to to do build openNURBS but to unzip the download, load the opennurbs_public.sln solution, and build.

I’m really confused as to what you are doing or what you have done.

– Dale