Opening "New" files


#1

Whenever I start a new file by either using the “New file” icon on the Standard ribbon bar or by going to File/New a new file is created in which seemingly by default the Model units are always in Centimeters, and the Layout units are in Millimeters. (See File/Setting/Units)

Because of the kind of work I do, I always want to start new files with both Model units and Layout units to be in millimeters.

So each time, I either have to change the Model unit setting is File/Setting/Units (in which case I also have to change the Absolute tolerance), or I have to create new files using File/New Using Template and then scroll all the way down to the bottom to Small Objects - Millimeters

Is there a way to change the default so that whenever I want to open a new file by using the “New file” icon or use File/New, that new file will always have the Model and Layout units in millimeters?


(John Brock) #2

When I start a new file, I get Inches but I can’t seem to find the U/I for setting which template to use as a default. I think it used to be there but I can’t find it now. I looked through Preferences and Settings but didn’t see it there either. The control should be on the MacRhino equivalent of the startup “splash” screen like it is in Windows Rhino, but I’m not seeing it.
This is probably a question for @marlin.


(Marlin Prowell) #3

In the opening splash screen, click the Show Templates field at the bottom of the window. Note that one of the templates is marked as the default template. To select one of the other templates as your default template, right click or control click the template.


(John Brock) #4

I see that now. I tried that earlier and I must have phat phingered it. I couldn’t find it.
This seems too subtle and hidden to me. Can we get a check box or a radio button that makes this more discoverable?


#5

This took me a while to figure out. Even though I followed Marlin’s instructions it would not work. My mistake was, I kept right clicking and control clicking on the grey field on the left that seems to represent a Rhino viewport. Nothing would happen.

Only after I right clicked on, above, below, or to the right of the text on the right of the grey fields would this work.