OpenGL issues with FirePro W8100 (FireGL V)

Hi,

I have some display problems using Rhino with a FirePro W8100.
Far objects appear over close objects, and some random far/near clipping occurs when moving in the viewports, even in Wireframe. In the Tool/Options View>OpenGL, the card & driver information reports 0bits Z-Buffer. I am running Windows 7 64 bit with the latest ATI Drivers.

I did not notice any issue with other software (SketchUp, 3dsMax, maya, games…)

Any idea?

Thanks!

That would certainly be a problem I guess, but I don’t know how to persuade the card, or Rhino, to see 24 bits… @jeff, can you help?

-Pascal

Can you please post a screenshot of Rhino’s OpenGL settings page. Rhino should actually fail altogether if it can’t find a pixel format that supports depth-buffering.

However, the Rendered mode uses what are called Frame Buffer Objects (FBO) that create and use their own depth buffer…so I’d be curious to hear if Rendered mode works for you. The information reported on the OpenGL screen is not necessarily the same information used by Rendered mode, so things might actually work in Rendered mode…just exploratory information and by no means an attempt at a workaround.

Note: Make sure Rendered mode is currently set to all of its defaults before trying anything.

Thanks,
-Jeff

Does the problem look like this to you?

Please find below some images : wireframe, shaded, rendered, and the OpenGL options dialog




You are right, disabling Anti-Aliasing fixes the problem. This can be a temporary fix, but not very satisfactory!