Rhino6 and FireGL (solved)


(Dirk Hagedorn) #1

I’m currently evaluating Rhino6 for Windows on a Win7-Pro-64 machine with an ATI FirePro V3800 (FireGL), and I’m quite disappointed.

Started with default settings and having created a sphere I see this:

Assuming that something is wrong with the OpenGL settings I opened the config and removed the check button for “GPU Unterteilung” (German for “GPU-Tessellation”). After having changed that, I see this:

No shadows, no surface, just the ISO lines(s). I see no points in the 2D views, no snap marks, print layouts show glitched and very ugly fonts, and so on and so forth…

Somethings seems to be completly wrong with Rhino6 while running completly perfect with Rhino5. :anguished:

Some more screenshots below with the other views. None of them works as supposed, the Raytracing view is unusably slow.

Rhino6 is broken for me and no candidate for license upgrades. What can I do?

System information:

Rhino 6 SR1 2018-1-23 (Rhino 6, 6.1.18023.13161, Git hash:master @ 92a80e9e2b29e4670a94deb0d656e234ca1fe036)

Windows 7 SP1 (Physical RAM: 16Gb)

ATI FirePro V3800 (FireGL) (OpenGL ver:4.0.10225 Compatibility Profile Context FireGL)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.0
Shading Language: 4.00
Driver Date: 1-15-2011
Driver Version: 8.773.1.1000
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB


#2

First thing I would do is update your video drivers, they are from 2011… --Mitch


(Nathan 'jesterKing' Letwory) #3

Also, Raytraced is supported only on GCN 2 and newer. Your V3800 is TerraScale 2, which is even pre-GCN 1. GCN 2 and newer are: https://en.wikipedia.org/wiki/Graphics_Core_Next#GCN_2nd_Generation_(Sea_Islands)

A RX 560 or RX 580 should do nicely (if you’re looking to upgrade), if you have money to burn than something more hefty would be even nicer ;)}


(Dirk Hagedorn) #4

Thanks, current drivers currently downloading, I’ll give it a try…


(Nathan 'jesterKing' Letwory) #5

Oh, and I just realized that OpenCL support for AMD cards works properly in the upcoming SR1 (6.1) that will be out hopefully relatively soon.


(Dirk Hagedorn) #6

A driver update solved the problems. Yes, I should have come up to that idea on my own :man_facepalming:

But, with the current AMD drivers Rhino6 is somewhat slower than Rhino5 - it feels like Rhino5 on a computer with onboard Intel graphics. OK, maybe it’s time for new hardware…