OpenCL Device gone

raytraced
opencl
cycles

#1

since the latest WIP i noticed, that raytraced display mode is using my CPU.
before it was using the RX460 with megakernel.
in the rhino options under cycles the OpenCL device disappeared and only the CPU is left.
also the command RhinoCycles_ListDevices only shows one device - the CPU.
by watching CPU / GPU clocks and utilization i can clearly tell that cycles actually uses the CPU and not the GPU anymore :frowning:

what happened?


(Nathan 'jesterKing' Letwory) #2

Right, I changed how determining OpenCL support is done somewhat. Although it should be in pretty good shape it is still not there by default.

You can ensure OpenCL devices show through Tools > Options > Advanced. Type OpenCL in the filter field. For device type set 1. For kernel type you can leave it on the default type -1. split kernel should work with RX 460. I have been testing with an RX 480 the last few days. 1 means forced split kernel, 0 means forced mega.


#3

SPLIT KERNEL?! AWESOME NEWS :fireworks:
i’ll try as soon as i’m back home at my AMD system.

btw:
you just released CyclesForRhino v0.1.4
tried it here in the office with my intel/nvidia system but on start, rhino gave me an error message regarding the plugin and cycles as standalone renderer is gone.


(Nathan 'jesterKing' Letwory) #4

Hmm, did you get a message on the command-line about it working only with WIP? Or any other message? You may have to reinstall the plugin to see the messages again.


#5

yes, the command line gives me the following message:
Cycles for Rhino works only with the WIP.
Unable to load CyclesForRhino.rhp plug-in: application initialization failed.

i already reinstalled the plugin a few times.
message after install:

message when starting rhino:

it was the same on my AMD system at home this morning.


(Nathan 'jesterKing' Letwory) #6

Hmm, I must have done Something Wrong, but not sure what. I compiled and tested this plug-in against the latest public WIP. What is your WIP version? (first line of SystemInfo output)


#7

Rhino 6 SR0 2017-5-16 (Rhino WIP, 6.0.17136.10381, Git hash:master @ 132f70880fccbff1340d813f10addb24f9d42fef)


(Nathan 'jesterKing' Letwory) #8

I have re-uploaded the .rhi file with a version that definitely works on my public WIP install. It is the same version as you have (tested several times now).

Could you please try the re-uploaded version?

Thanks.

/Nathan


#9

re-downloaded and re-installed it on the home system.
still the same plugin error.

i’ll try in the office shortly.

hope i won’t have to reinstall rhino


#10

it’s getting weird.
just tried it in the office and now i get this message when i try to re install the 0.1.4 rhi:

EDIT:
now i wanted to re install the latest rhino wip. there was a “repair” option - i tried that.
after that i could successfully install the v0.1.4 again.
but on start i get the same error message for the plugin like before - i hate this!

ASIDE:
the split kernel works for my RX460 and raytrayced display mode. compiling took quite a while. but it’s terribly slow! of course the RX460 is a low end card but it was much slower than the cpu - AMD A10-7800. changing the tile size to 512x512 made a huge improvement but it was still not really faster than the CPU. shouldn’t a RX460 outperform such a slow and old CPU?


(Nathan 'jesterKing' Letwory) #11

I am not sure why the plug-in won’t load for you. I’ll have to create a test command that helps me diagnose the issue.

The only thing I can currently think of is that your system time could be wrong. But as said I’ll create a test command and will ask you to test.

RX 460 being slow would depend on its architecture. GCN1 would currently mean slow, but I’ll check the internet for info when I am not on the road (:


#12

system time?
my system time is german time - what’s wrong with that?!
:confused:


(Nathan 'jesterKing' Letwory) #13

Nothing wrong with that. It is just that I added a timer in the plug-in. It is now 7 days usable since plug-in build. This is to ensure users of the plug-in update regularly. I see still lots of exception reports due to old plug-in versions.

Anyway, I’ll have that test command at some point. Probably on Monday as the weekend.has already started.


#14

just installed the latest WIP on the AMD system and reinstalled the 0.1.4.rhi as well.
again:

Loading Rhino Render, version 1.50, May 23 2017, 09:19:50
Cycles for Rhino is too old, get a newer version from https://github.com/mcneel/CyclesForRhino/releases/latest
Unable to load CyclesForRhino.rhp plug-in: application initialization failed.

:cry:

maybe there are still some old files, which the .rhi is not able to overwrite? i have no idea what i’m talking about :confused:

and something else. i’ve never seen this symbol in my wip:

looks like this at my wip:


(Nathan 'jesterKing' Letwory) #15

I haven’t made necessary changes yet as I am waiting on some crucial information. I’ll notify you on the forum when it is time to test again. For now I think you should be able to use https://github.com/mcneel/CyclesForRhino/releases/tag/0.1.2 (untested)


#16

did that. plugin loads without errors now. but when the current renderer is cycles for rhino, nothing happens when i want to _Render

no big deal for me, just wanted to let you know.

what about the missing symbol?
i guess i’m missing something?


(Nathan 'jesterKing' Letwory) #17

Ah, the missing symbol is an advanced setting (Options > Advanced), AllowViewportOverride I think the setting is called. You can type that in the filter field. You don’t need the CyclesForRhino plug-in for that.

Or rather, it is not a symbol, but a viewport properties tab (:


#18

got it, thanks